If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

BrowserID popup is being blocked by Firefox

VERIFIED FIXED in 6.3.3

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: gkoberger)

Tracking

unspecified
6.3.3

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://addons-dev.allizom.org/en-US/firefox/
2. Click Login/Register

expected behavior:
BrowserID popup opens

actual behavior:
BrowserID popup is blocked by Firefox

screencast: http://screencast.com/t/MadMFhlM0

I have seen this happen on apps-preview-dev as well, so i am making this a blocker for 690899
(Reporter)

Comment 1

6 years ago
Error: b is null
Source File: https://browserid.org/include.js?_=1321919917885
Line: 37


Error: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 864"  data: no]
(Reporter)

Comment 2

6 years ago
I filed https://github.com/mozilla/browserid/issues/628
Priority: -- → P1
Assignee: nobody → gkoberger
Target Milestone: --- → 6.3.3
(Assignee)

Comment 3

6 years ago
I was trying to be creative by loading BrowserID on the fly, but that won't work. Fixed!

https://github.com/mozilla/zamboni/commit/0a10cfb56491bca9ff151ffd8fa8213e1d5cddec

Krupa claims it sometimes randomly happened before my changes, but for now we'll close it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

6 years ago
I cannot reproduce this issue anymore.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.