bump versions for hotfix-1.5 and release Mozmill 1.5.7 to pypi

VERIFIED FIXED

Status

Testing Graveyard
Mozmill
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: Jeff Hammel, Assigned: Jeff Hammel)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
A new 1.5 series should be version-bumped and released to pypi for the
fix in bug 658509 .
(Assignee)

Comment 1

7 years ago
Created attachment 576081 [details] [diff] [review]
version bump to 1.5.7

bumps mozmill and mozrunner versions.  jsbridge should not have been changed
Attachment #576081 - Flags: review?(ctalbert)
Assignee: nobody → jhammel
Status: NEW → ASSIGNED
Summary: bump versions for hotfix-1.5 and release to pypi → bump versions for hotfix-1.5 and release Mozmill 1.5.7 to pypi

Comment 2

7 years ago
Comment on attachment 576081 [details] [diff] [review]
version bump to 1.5.7

thanks!
Attachment #576081 - Flags: review?(ctalbert) → review+
(Assignee)

Comment 3

7 years ago
Actually, this won't work :(  We do need to bump the jsbridge version because for some reason it depends on mozrunner ("historical reasons").  Since the mozrunner version is bumped, even though it is bumped correctly in jsbridge, you cannot bump it on pypi jsbridge this way.

2.0 ftw
Hm why not? There is no jsbridge package on pypi which is for Mozmill 2 and above. Or is the mozrunner package the problem?
(Assignee)

Comment 5

7 years ago
The problem is that mozmill depends on jsbridge and mozrunner and jsbridge depends on mozrunner.  This is the piece I had forgotten about (it shouldn't, but that's another story) and that breaks this plan.  If we bump the mozmill and mozrunner versions and push them to pypi, mozmill will install the existing jsbridge and the new mozrunner.  However, because we peg our versions, jsbridge will want the old mozrunner.  setuptools will be unable to satisfy dependencies and bad things will happen (i.e. a broken installation).
Oh, so it only needs a version bump of jsbridge too? Means a simple update of the patch?
(Assignee)

Comment 7

7 years ago
Created attachment 576521 [details] [diff] [review]
version bump to 1.5.7

bumps all versions
Attachment #576081 - Attachment is obsolete: true
Attachment #576521 - Flags: review?(hskupin)
(Assignee)

Comment 8

7 years ago
(In reply to Henrik Skupin (:whimboo) from comment #6)
> Oh, so it only needs a version bump of jsbridge too? Means a simple update
> of the patch?

That is correct, reflected in attachment 576521 [details] [diff] [review]
Comment on attachment 576521 [details] [diff] [review]
version bump to 1.5.7

Looks good. Thanks for the clarification Jeff. Lets get it landed and Mozmill 1.5.7 released.
Attachment #576521 - Flags: review?(hskupin) → review+
(Assignee)

Comment 11

7 years ago
pushed to pypi; easy_install mozmill in a blank virtualenv works
(Assignee)

Comment 12

7 years ago
tagged https://github.com/mozautomation/mozmill/commits/1.5.7
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Looks good. Thanks Jeff!
Status: RESOLVED → VERIFIED
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.