Intermittent xpcshell "process killed by signal 9" during xpcom/tests/unit/test_nsIProcess_stress.js

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({intermittent-failure})

11 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=7511631&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound debug test xpcshell on 2011-11-21 11:21:54 PST for push 15ce8c86aa56

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/xpcom/tests/unit/test_mac_bundle.js | test passed (time: 82.651ms)
TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/xpcom/tests/unit/test_nsIMutableArray.js | running test ...
TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/xpcom/tests/unit/test_nsIMutableArray.js | test passed (time: 91.990ms)
TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/xpcom/tests/unit/test_nsIProcess.js | running test ...
TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/xpcom/tests/unit/test_nsIProcess.js | test passed (time: 225.099ms)
TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/xpcom/tests/unit/test_nsIProcess_stress.js | running test ...
process killed by signal 9
program finished with exit code -1
elapsedTime=1000.421124
TinderboxPrint: xpcshell<br/><em class="testfail">T-FAIL</em>
Unknown Error: command finished with exit code: -1
Whiteboard: [orange][test which aborts the suite] → [test which aborts the suite]
(In reply to Ed Morley [UTC+0; email:edmorley@moco] from comment #58)
> This has dramatically picked up in frequency recently :-(

And my retriggers are inconclusive :-(

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=dfc5eeb57fce&jobname=Rev3%20Fedora%2012x64%20mozilla-inbound%20debug%20test%20xpcshell
(press down once)
Mike, the test in test_nsIProcess_stress.js used to live in test_nsIProcess.js and was added by you in http://hg.mozilla.org/mozilla-central/rev/5e3ddc9cd1c5

Please may you take a look at this? The failure mode doesn't given TBPL anything to match/show in the summary, so it would be really helpful to sheriffs (and people using Try who may not recognise the failure from the raw log) to have this fixed.

Thank you :-)
Flags: needinfo?(mh+mozilla)
Just seems to be failing on Linux64 debug at the moment (though isn't run on Windows due to bug 676412). Full failure history at:
http://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=704368&entireHistory=true&tree=all
This makes no sense to me. Not only shouldn't the test kill xpcshell (it's only killing subprocesses), but it shouldn't prevent subsequent tests from running either. Ted, does the xpcshell harness abort when one test crashes/is killed?
Flags: needinfo?(mh+mozilla) → needinfo?(ted)
No, the harness handles that gracefully:
http://mxr.mozilla.org/mozilla-central/source/testing/xpcshell/runxpcshelltests.py#860

This looks like something is SIGKILLing the entire harness. Perhaps it's attracting the OOMkiller on Linux64 debug?
Flags: needinfo?(ted)
Oh, could there be a fork-bomb killer on the test slaves?
For the time being perhaps we should just skip this test on linux64 debug.
I'm not really sure what the root cause is, but skipping it here seems reasonable.
Attachment #689699 - Flags: review?(mh+mozilla)
Thank you Ted! :-)
Attachment #689699 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/a4c7e07abd65
Whiteboard: [test which aborts the suite] → [test which aborts the suite][test disabled on Linux64][leave open]
100/100 green runs on Try. Re-enabling.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=1cf4d504f15e

https://hg.mozilla.org/integration/mozilla-inbound/rev/26a04a373ecc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [test which aborts the suite][test disabled on Linux64][leave open]
Assignee: ryanvm → nobody
You need to log in before you can comment on or make changes to this bug.