Ensure prepare_test hash is ALWAYS uniquely regenerated on each revision change

RESOLVED FIXED in Builder 1.0

Status

addons.mozilla.org Graveyard
Add-on Builder
P1
blocker
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: dbuc, Assigned: seanmonstar)

Tracking

unspecified
Builder 1.0

Details

(Reporter)

Description

6 years ago
Right now in the app, the frontend is failing to generate unique hashes for its prepare_test POST calls. This is causing the backend to ignore fresh compilation of new revisions and instead send out the previously existing XPI at that hash location.

This needs to be fixed and pushed this week. Branch off of the current live code tag and fix this alone, we will push only this change on Wednesday.
(Reporter)

Updated

6 years ago
Assignee: nobody → smcarthur
Priority: -- → P1
Target Milestone: --- → Builder 1.0
(Reporter)

Updated

6 years ago
Blocks: 697973
Could you provide the steps to reproduce?

I'm checking the POST data and URLs in Edit Mode, and these are changing in frontend for every click.

I'm checking also the View Mode and the hashtag there is changed with every save (depends on revision number).
(Assignee)

Comment 2

6 years ago
The good news is that this doesn't affect production, because this was introduced when I re-wrote things for Shipyard, and that still hasn't hit prod yet. I can easily fix this bug for -dev, though.

The bad news is that this isn't the real reason why bug 697973 is happening.
(Assignee)

Comment 3

6 years ago
fixed for master

https://github.com/mozilla/FlightDeck/commit/2722723c860ce201218654fa93e57154b3a68b89
No longer blocks: 697973
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.