mozilla fails to function when using xul scripts tagged as application/x-javascript

VERIFIED FIXED

Status

()

Core
HTML: Parser
--
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: timeless, Assigned: brendan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
<xul:script type="application/x-javascript" src="chrome://..."/> 
steps to reproduce:
open your navigator.xul
replace text/j with application/x-j
save.
dist this file if necessary.
run mozilla

expecected results: mozilla navigator runs normally.

actual results: a void window w/ no user elements.
(Assignee)

Comment 1

18 years ago
Bug's in the XUL content sink, not in the parser.

/be
Assignee: harishd → waterson
(Assignee)

Comment 2

18 years ago
Created attachment 26409 [details] [diff] [review]
proposed fix
(Reporter)

Comment 3

18 years ago
looks good to me
Blocks: 65428
Keywords: approval, review

Comment 4

18 years ago
Should this be factored and moved to 
mozilla/content/base/src/nsParserUtils.[h|cpp]? (In other words, do XML and HTML 
do the same thing?) If not, [r|sr]=waterson

Comment 5

18 years ago
updated qa contact.
QA Contact: janc → bsharma

Comment 6

18 years ago
brendan: you've got r= & sr=, and the patch is in your tree. Kickin' the bug 
right atcha.
Assignee: waterson → brendan
(Assignee)

Comment 7

18 years ago
Done.

/be
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

17 years ago
erm, i thought i already verfied this, well
vrfy fixe 3/10-08 w32
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.