Last Comment Bug 704392 - login panel for sync needs UX
: login panel for sync needs UX
Status: RESOLVED INVALID
[needs-ux]
:
Product: Web Apps
Classification: Other
Component: Extension (show other bugs)
: unspecified
: x86 Mac OS X
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 704652 709304 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 19:23 PST by Shane Caraveo (:mixedpuppy)
Modified: 2014-03-17 10:43 PDT (History)
9 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
startup login panel (33.96 KB, image/png)
2011-11-21 19:25 PST, Shane Caraveo (:mixedpuppy)
no flags Details

Description Shane Caraveo (:mixedpuppy) 2011-11-21 19:23:00 PST
The sync code introduces a login panel at startup that doesn't indicate what it is for, and further if you don't login, there is no mechanism to get it back, you must restart to login.  I'm assuming this is a login needed in order to sync your apps since it is from that branch, but otherwise I wouldn't know by looking.
Comment 1 Shane Caraveo (:mixedpuppy) 2011-11-21 19:25:31 PST
Created attachment 576072 [details]
startup login panel
Comment 2 Anant Narayanan [:anant] 2011-11-28 14:25:08 PST
*** Bug 704652 has been marked as a duplicate of this bug. ***
Comment 3 Bryan Clark (DevTools PM) [:clarkbw] 2011-11-30 06:34:57 PST
Yeah, this is crap.  :)  Can we move this login into the apps dashboard instead?  https://people.mozilla.com/~faaborg/files/projects/apps/creation-i1/added.html

I'm not entirely clear why we need to have people login at this moment.  The dashboard is the place where you want to sync your apps up so that seems like the best spot to have people login.
Comment 4 Dan Walkowski 2011-12-02 10:34:01 PST
It definitely needs UI/X to make it pretty, my thinking was that it would be nicer to be able to log in immediately, so that app syncing is happening in the background, (the job of the addon, not the dashboard) , so that when you do go to the dashboard, everything is up to date.
Comment 5 Ian Bicking (:ianb) 2011-12-02 11:23:17 PST
If we schedule the sync service correctly (and it may not be right now!) then the update of the dashboard should be quite fast after login.
Comment 6 Bill Walker [:bwalker] [@wfwalker] 2011-12-02 16:11:25 PST
Jen feels this is not a release blocker
Comment 7 dclarke@mozilla.com [:onecyrenus] 2011-12-09 14:14:17 PST
*** Bug 709304 has been marked as a duplicate of this bug. ***
Comment 8 Jason Smith [:jsmith] 2012-02-11 16:14:18 PST
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/24808701

Note You need to log in before you can comment on or make changes to this bug.