Last Comment Bug 704451 - Switching to unread filter hides all my email
: Switching to unread filter hides all my email
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Thunderbird 11.0
Assigned To: David :Bienvenu
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 04:06 PST by Ludovic Hirlimann [:Usul]
Modified: 2011-12-01 13:57 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
this implements the method (6.47 KB, patch)
2011-11-22 11:53 PST, David :Bienvenu
neil: review+
Details | Diff | Review

Description Ludovic Hirlimann [:Usul] 2011-11-22 04:06:10 PST
STR :

1) Open your bugmail folder ( View Threads with unread is my choice)
2) Select the unread button on the QFB

All unread messages that were visible are no more visible.

I see
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIMsgDBView.numMsgsInView]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: resource:///modules/dbViewWrapper.js :: DBViewWrapper__applyViewChanges :: line 1388"  data: no] in the error console.
Comment 1 Ludovic Hirlimann [:Usul] 2011-11-22 05:07:28 PST
Seems to be related to the fact that I don't have any active filter , I just click on the unread button.
Comment 2 Ludovic Hirlimann [:Usul] 2011-11-22 09:10:38 PST
Trying STRs proper for bienvenu :


View -> Sort by -> Threaded, date, ascending
View -> Messages -> All
View Threads -> Unread

go to QFB , click the unread button -> empty view
Comment 3 David :Bienvenu 2011-11-22 09:11:10 PST
Any extensions (e.g., Conversations) installed?
Comment 4 David :Bienvenu 2011-11-22 11:53:34 PST
Created attachment 576220 [details] [diff] [review]
this implements the method

I'm not convinced this exception is why the view is empty for you, because I see the exception but the message list is still displayed. But I can generate a try server build for you to try.
Comment 5 David :Bienvenu 2011-11-22 12:46:39 PST
try builds will show up here, if they succeed - http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/bienvenu@nventure.com-ed7af9cec215
Comment 6 Ludovic Hirlimann [:Usul] 2011-11-25 08:29:51 PST
(In reply to David :Bienvenu from comment #5)
> try builds will show up here, if they succeed -
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/
> bienvenu@nventure.com-ed7af9cec215

Spot on. The view is still empty when I use the try build - but I'm not seeing the exception.
Comment 7 David :Bienvenu 2011-11-25 09:04:03 PST
Comment on attachment 576220 [details] [diff] [review]
this implements the method

well, it wouldn't hurt to implement this, if only for consistency's sake, and to get rid of the exception.
Comment 8 neil@parkwaycc.co.uk 2011-11-25 13:08:31 PST
Comment on attachment 576220 [details] [diff] [review]
this implements the method

Looks reasonable although we don't seem to use numMsgsInView in SeaMonkey.
Comment 9 David :Bienvenu 2011-12-01 13:57:01 PST
http://hg.mozilla.org/comm-central/rev/1263a8067986

Note You need to log in before you can comment on or make changes to this bug.