Annotate ReleaseChannel even earlier during startup

RESOLVED FIXED in mozilla11

Status

()

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Trunk
mozilla11
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Currently we add the ReleaseChannel annotation by getting the preference value, which is pretty deep into startup. If we crash before that, we won't get a ReleaseChannel.

We can annotate the default value from MOZ_RELEASE_CHANNEL immediately after we enable crash reporting, which should be a sane value most of the time.
Created attachment 576154 [details] [diff] [review]
Annotate ReleaseChannel with MOZ_UPDATE_CHANNEL earlier in startup

Simple patch. I tested by adding an intentional crash right after the crashreporter block, and I saw "ReleaseChannel=default" in the crashreporter details window.
Attachment #576154 - Flags: review?(benjamin)

Updated

7 years ago
Attachment #576154 - Flags: review?(benjamin) → review+

Comment 3

7 years ago
https://hg.mozilla.org/mozilla-central/rev/e71c177db52e
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
Comment on attachment 576154 [details] [diff] [review]
Annotate ReleaseChannel with MOZ_UPDATE_CHANNEL earlier in startup

[Approval Request Comment]
Regression caused by (bug #): <not a regression>
User impact if declined: Crash analysis on some startup crashes is more difficult.
Testing completed (on m-c, etc.): The patch landed on mozilla-central and made it to aurora during the migration.
Risk to taking this patch (and alternatives if risky): Low risk, simply adds one more annotation during startup to the existing set.

We don't have to take this patch, it's not a regression fix and it doesn't actual fix any crashes. It simply provides the release channel data in certain circumstances where we don't normally get it. Namely, startup crashes that happen before the user profile has been located. The crash data is still available, it's just not associated with a release channel, which means it fails to show up in certain reports.
Attachment #576154 - Flags: approval-mozilla-beta?

Comment 5

7 years ago
Comment on attachment 576154 [details] [diff] [review]
Annotate ReleaseChannel with MOZ_UPDATE_CHANNEL earlier in startup

This can wait the four weeks and ride the trains. Thanks, though, for the very informative approval request, Ted.
Attachment #576154 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Duplicate of this bug: 671010
You need to log in before you can comment on or make changes to this bug.