Automatic install doesn't start after purchase with the HTML5 implementation

RESOLVED FIXED in 6.3.4

Status

P1
normal
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: andy+bugzilla)

Tracking

unspecified
6.3.4
Dependency tree / graph

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Make sure you DON'T have the OWA extension installed.
2. Load https://apps-preview-dev.allizom.org/en-US/apps/app/marble-run/?src=cb-dl-home
3. Purchase the app

expected behavior:
After purchase, automatic install starts with confirmation box showing up.

actual behavior:
After purchase, automatic install doesn't start.
Priority: -- → P1
Target Milestone: --- → 6.3.3
Target Milestone: 6.3.3 → 6.3.4
(Reporter)

Updated

7 years ago
Duplicate of this bug: 707581
(Assignee)

Comment 2

7 years ago
There's a couple of issues locally that this exposes:

1) the apps.install method fails and is dropping us into https://github.com/mozilla/zamboni/blob/master/media/js/zamboni/apps.js#L86, showError. This is another modal and there's something in the timing that is wrong.

2) having the thank you modal removed and replaced with an error modal is horrid and not helpful to the user.

3) why is apps.js install failing in the first place.

I need to solve 3) and I think 2) needs to be handled in a different way. 1) might just be a bug in modals/timing/callbacks/js/life in general.
(Assignee)

Comment 3

7 years ago
Example (when my data is bit messed up) http://screencast.com/t/zPQcMdia0
(Assignee)

Comment 4

7 years ago
I'm getting: uncaught exception: Channel.build() called without a valid window argument

This looks related: https://github.com/mozilla/browserid/issues/75 thanks @cvan.
(Reporter)

Updated

7 years ago
Blocks: 707957
(Assignee)

Comment 5

7 years ago
This is a workaround. Lots of  credit to @cvan, awesome help thank you.

https://github.com/mozilla/zamboni/commit/cc744d

Will file a bug for the modals, but that's low priority.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.