Non-loading images cause blank pages upon stop.

VERIFIED WORKSFORME

Status

()

Core
Layout
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Scott Anderson, Assigned: karnaze (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20smp i686; en-US; 0.9) Gecko/20010226
BuildID:    2001022608

ezBoard, the site in the URL, currently has an advertiser with an
extraordinarily slow server. To fix the problem, a number of people either try
to hit 'escape' to stop the image from loading, or put the image server in their
DNS as 127.0.0.1 so it doesn't get pulled.

Mozilla, when presented with either of these situations, displays a blank page.
In the first case, hitting 'escape' stops the image load, but nothing is
displayed by Mozilla (despite the HTML being complete as shown by Show Page
Source). In the second case, the page loads immediately, but nothing is shown by
Mozilla (again, despite the HTML being complete).

Reproducible: Always
Steps to Reproduce:
Visit the URL. While the image is being requested (should take a good minute),
hit 'escape'. The page will show blank, but Show Page Source will show that the
HTML is complete.

Next, put www1.bigbangmedia.com in /etc/hosts to point to 127.0.0.1
(bigbangmedia is the server that redirects to 216.52.103.55, which is the slow
image server). Load the URL. The page should load immediately, but not display
anything.

Gnome 1.2, X 4.0.2, behind a proxying firewall.
The issue is that what is actually being loaded off www.bigbangmedia.com is a
script included in <head> with <script src="...">

Since this is in <head> it has to be loaded and executed before the body is
displayed.  So if you hit stop you get nothing....

Not sure what's going on when the script can't get loaded becaues it's
redirected to 127.0.0.1
(Reporter)

Comment 2

17 years ago
Interestingly, turning off Javascript in the preferences has no effect on this
behaviour. That's probably a different bug, however.

Comment 3

17 years ago
Scott,

Is this still a issue in the latest build ?
(Reporter)

Comment 4

17 years ago
Seems to work with build 2001041214.

Comment 5

17 years ago
Based on the previous comments, marking works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.