Linux mouse copy/paste confuses browser

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Pierre Fortin, Unassigned)

Tracking

11 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

15.18 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 576256 [details]
compose.pl

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111121 Firefox/11.0a1
Build ID: 20111121092346

Steps to reproduce:

using webmail, selected Forward as Attachment which returns a new window (received code attached) with my email address pre-populated in the BCC field.  


Actual results:

If I:   a) type an address into the To: inputbox, all is OK
b) Ctrl+c or Ctrl+x and Ctrl+v the BCC address into the To: inputbox, also OK.

However, if I use Linux mouse copy (select text in BCC) and middle-click paste it into To:, the To: inputbox is locked.  I can select that pasted text, but can't edit or delete it.  If I hit Send Message, the pasted text is not sent to the host which complains there is no To address specified.


Expected results:

Accept mouse pasted text just like Ctrl+v pasted text.

Comment 1

6 years ago
openSUSE 12.1, 32bit system, running Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120215 Firefox/13.0a1, i was unable to reproduce your situation. 
I have opened both my yahoo and gmail accounts and started to use copy and paste via mouse and the selected e-mail addresses where copied just fine. Do you still experience this if you upgrade to version 13 of Firefox ?
(Reporter)

Comment 2

6 years ago
Looks like it got fixed mysteriously.... :)

Comment 3

6 years ago
Considering comment 2 will resolve this as WORKSFORME. Feel free to reopen if the problem comes back!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.