Crash when starting mozilla with profile stored in custom folder

VERIFIED WORKSFORME

Status

Core Graveyard
Profile: BackEnd
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Grace Bush, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
build 2001022705
1. run profile manager
2. create a new profile- choose to store in custom directory vs default 
directory
3. choose to start mozilla

actual results: crash every time  (second attempt with that profile will launch)
expected result: launch mozilla
(Assignee)

Comment 1

17 years ago
Just tried that with a debug build made this morning and it worked fine. I'll
pull the exact build you said from sweetlou and see what happens. What was the
path of the custom dir your picking?
(Reporter)

Comment 2

17 years ago
I used the mozilla build located here 
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
for 2/27
I used a few directories- one on c:\ and another I use for regular testing (with 
commercial product)  D:\customprofiles 

fwiw, I saw this months ago with commercial product too but it was fixed.
(Assignee)

Comment 3

17 years ago
Using /2001-02-27-06-Mtrunk/ from sweetlou also works for me. Can this be
reproduced on any other machines? Can we get a stack trace? 
(Reporter)

Comment 4

17 years ago
does not occur on win2000
I have a dr. watson log- no talkback as I never launch
(Assignee)

Comment 5

17 years ago
> does not occur on win2000
I'm running NT4 and it's not happening for me.

> I have a dr. watson log- no talkback as I never launch
Anything helps :-)
(Reporter)

Comment 6

17 years ago
Created attachment 26411 [details]
dr watson log
(Reporter)

Comment 7

17 years ago
I am using NT also- sp4 I believe, can reproduce every time :(
(Reporter)

Comment 8

17 years ago
*** Bug 70637 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

17 years ago
nominating
Conrad,  see bug 27573 - one of most duplicated bugs 
Keywords: nsbeta1
(Assignee)

Comment 10

17 years ago
As of today, still WFM. Can we get this to happen on a machine with a debugger?
I couldn't tell anything from the dr.watson log. Bhuvan?
(Assignee)

Comment 11

17 years ago
Still need help in reproducing.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
(Reporter)

Comment 12

17 years ago
Sorry to report this still happens to me intermittently on NT. :(
 Sometimes it does work but more often it crashes when I select that profile and 
press the StartNetscape button. I can use that profile after the crash
(Assignee)

Comment 13

17 years ago
I wonder if this could be related to bug 74118. In that bug, it would crash
after making a new profile and starting mozilla. That bug was not in the profile
manager but had to do with what windows were brought up during profile creation.
The fact that the profile that gets created when this crash happens is also the
same as bug 74118 and makes me think it's not profile mgr itself. Grace, does
this still happen - even intermittently?
(Reporter)

Comment 14

17 years ago
I haven't seen this for the past week or so...just tried again with 4/3 build 
and it is working.  Over the project this has recurred - and you may be right, 
the problem is elsewhere since it comes and goes without PM changes
(Assignee)

Comment 15

17 years ago
Based on that, marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

17 years ago
verify
Status: RESOLVED → VERIFIED

Comment 17

17 years ago
*** Bug 82049 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Reopening this bug based on findings in bug 82049.  Here are some observations I 
had originally posted in 82049:

Perhaps my statement of "Upon starting the browser" is misleading.  The last 
step is to click "Finish"--then the page fault occurs.

I have since discovered a difference in behavior between WinMe-Ja and Win98-En. 
This difference actually does depend on whether the mouse is used to do some of 
the steps.  On WinMe-Ja, the page fault does not occur until clicking with the 
mouse on "Finish".  On Win98-En, if I use the keyboard to choose the folder, the 
page fault occurs when clicking on "Finish" (with the keyboard, I could tab over 
to "Finish", but hitting Enter had no effect).  However, if I choose the folder 
with the mouse, the page fault occurs when I confirm the selection by clicking 
on OK.  If I choose the folder with the keyboard and then use the mouse to click 
OK, the page fault doesn't occur until clicking on "Finish".  So at least on 
Win98-En, use of the mouse plays a role in the timing of when the bug occurs.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 19

17 years ago
In Win98-EN, even with *all* profiles created in the default directory, the
crash still exist.  I've filed that in Bug 81830.

Comment 20

17 years ago
resetting milestone from m.9 to ---.  If this is an m.9.1 stopper, please get it
on the list and approved.
Target Milestone: mozilla0.9 → ---
(Reporter)

Comment 21

17 years ago
this is not happening for me with recent builds/ either Mozilla or Netscape 6
markign wfm
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 22

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.