If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After editing and closing tabs for a while, save will not unlight the save button, throws an error

RESOLVED FIXED in Builder 1.0

Status

addons.mozilla.org Graveyard
Add-on Builder
P2
critical
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: dbuc, Assigned: seanmonstar)

Tracking

unspecified
Builder 1.0
x86_64
Windows 7

Details

(Reporter)

Description

6 years ago
Here is the error I am seeing:

Error: item is null
Source File: https://builder.addons.mozilla.org/media/lib/mootools/mootools-core-1.3.2.js
Line: 936
(Reporter)

Updated

6 years ago
Assignee: nobody → smcarthur
Severity: normal → critical
Priority: -- → P2
Target Milestone: --- → Builder 1.0
(Reporter)

Comment 1

6 years ago
Just save a bunch back and forth between many tabs and mix in some test button hits to trigger this.
(Assignee)

Comment 2

6 years ago
Similar with this one, is there anymore specific of a situation that you could provide? So far, I can't reproduce this.
(Assignee)

Comment 3

6 years ago
However, I did run into another error while testing this (that if you closed the first tab on the left, you could then close all the tabs). It turned out that closing the first tab only destroyed the element, but left the editor instance around. That could have been the reason this was happening as well.
(Assignee)

Comment 4

6 years ago
If this can no longer be reproduced, then I'm going to say it was related to the other bug and is now fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.