Closed Bug 704662 Opened 10 years ago Closed 10 years ago

crash in mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder @ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod

Categories

(Core Graveyard :: Widget: Android, defect)

10 Branch
ARM
Android
defect
Not set
critical

Tracking

(firefox11 affected, firefox12 affected, firefox13 affected)

RESOLVED DUPLICATE of bug 721086
Tracking Status
firefox11 --- affected
firefox12 --- affected
firefox13 --- affected

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [native-crash], startupcrash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-dd79977d-39b9-4440-a08b-cb1d02111120 .
============================================================= 
Frame 	Module 	Signature [Expand] 	Source
0 	libdvm.so 	JNI_CreateJavaVM 	
1 	libxul.so 	_JNIEnv::CallObjectMethod 	jni.h:617
2 	libxul.so 	mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder 	widget/src/android/AndroidJavaWrappers.cpp:649
3 	libxul.so 	mozilla::AndroidBridge::CallEglCreateWindowSurface 	widget/src/android/AndroidBridge.cpp:884
4 	libxul.so 	mozilla::gl::CreateSurfaceForWindow 	gfx/thebes/GLContextProviderEGL.cpp:1903
5 	libxul.so 	mozilla::gl::GLContextProviderEGL::CreateForWindow 	gfx/thebes/GLContextProviderEGL.cpp:1943
6 	libxul.so 	nsWindow::GetLayerManager 	widget/src/android/nsWindow.cpp:764
7 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1090
8 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1145
9 	libxul.so 	nsWindow::OnDraw 	widget/src/android/nsWindow.cpp:1186
10 	libxul.so 	nsWindow::OnGlobalAndroidEvent 	widget/src/android/nsWindow.cpp:982
11 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/android/nsAppShell.cpp:425
12 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:171
13 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:312
14 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:595
15 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
16 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
17 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
18 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
19 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
20 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:228
21 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3551
22 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:139
23 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:232
24 	libdvm.so 	dvmPlatformInvoke 	
25 	libdvm.so 	dvmCallJNIMethod_general 	
26 	libdvm.so 	dvmResolveNativeMethod 	
27 	libdvm.so 	dvmAsmSisterStart 	
28 	libdvm.so 	dvmMterpStd 	
29 	libdvm.so 	dvmInterpret 	
30 	libdvm.so 	dvmCallMethodV 	
31 	libdvm.so 	dvmCallMethod 	
32 	libdvm.so 	dvmDetachCurrentThread 	
33 	libc.so 	libc.so@0x11e5a 	
34 	libc.so 	libc.so@0x11a36
They are mainly startup crashes.
Depends on: 704660
Whiteboard: [native-crash] → [native-crash], startupcrash
Crash Signature: [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod] → [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod] [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod | mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder]
Summary: crash [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod ] → crash in mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder @ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod
Occurs in Aurora/Nightly still occurs in yesterday's build on both aurora/nightly

https://crash-stats.mozilla.com/report/list?product=FennecAndroid&query_search=signature&query_type=contains&query=JNI_CreateJavaVM | _JNIEnv%3A%3ACallObjectMethod&reason_type=contains&date=01%2F24%2F2012 16%3A22%3A12&range_value=30&range_unit=days&hang_type=any&process_type=any&do_query=1&signature=JNI_CreateJavaVM | _JNIEnv%3A%3ACallObjectMethod
Crash Signature: [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod] [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod | mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder] → [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod] [@ JNI_CreateJavaVM | _JNIEnv::CallObjectMethod | mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder] [@ _JNIEnv::CallObjectMethod | mozilla::AndroidGeckoSurfaceView::GetSurfaceHolder]
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721086
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.