On closing down Mozilla 0.9 Necko.dll crashed

RESOLVED DUPLICATE of bug 65798

Status

()

RESOLVED DUPLICATE of bug 65798
18 years ago
16 years ago

People

(Reporter: elst93, Assigned: neeti)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; 0.8) Gecko/20010215
BuildID:    Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; 0.9) Gecko/20010223

I had opened up Mozilla 0.9 on it's own without an internet connection. I
checked the build-id number and checked if it would still not make an
internetconnection when I tried to load the release notes. It didn't resolve the
page, so it wouldn't call in without me knowing (which is good).

I then closed down Mozilla, and it came back with a report that NECKO had
crashed, Mozilla would now be closed.

I used Talkback to send you the report, but it didn't come back with an incident
ID. You might want to check on my email-address (elst93@wxs.nl) for latest reports.

Reproducible: Sometimes
Steps to Reproduce:
Close down your internet connection, set Windows not to dial in, or use the
internet ever. (so, never dial a connection)
Open up Mozilla, load the release notes.
Close down Mozilla after about 10 seconds.

Actual Results:  After Mozilla had closed down (so it's no longer visible on
screen) it came up with a Windows error box saying NECKO had crashed. If I would
be so good to press OK to close down Mozilla.

Expected Results:  Just close down Mozilla without errors.

With older versions of Mozilla I had to reboot after such an error occurred, as
Mozilla would refuse to start up again. The non-talkback version still has this
problem, but the Talkback version does not anymore.

Comment 1

18 years ago
notwerk
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → tever
(Reporter)

Comment 2

18 years ago
The Talkback Incident ID finally resolved. It's TB27070196M

Comment 3

18 years ago
   nsCacheManager::NoteDormant  
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCacheManager.cpp, line 344]   
     nsCachedNetData::Release  
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCachedNetData.cpp, line 265]  
      nsCOMPtr_base::assign_with_AddRef  
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 59]        
nsHTTPChannel::ResponseCompleted  
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line
1754]         nsHTTPPipelinedRequest::OnStopRequest  
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPRequest.cpp, line
914]         nsSimpleStreamListener::OnStopRequest  
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsSimpleStreamListener.cpp, line
56]         nsOnStopRequestEvent::HandleEvent  
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamObserverProxy.cpp, line
178]         nsStreamObserverEvent::HandlePLEvent  
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamObserverProxy.cpp, line
78]         PL_HandleEvent  
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 577]        
PL_ProcessPendingEvents   [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 513]         nsEventQueueImpl::ProcessPendingEvents  
[d:\builds\seamonkey\mozilla\xpcom\threads\nsEventQueue.cpp, line 362]        
0x006a17f0             0x006a17f0             0xf000e987             0x8b000466    

Comment 4

18 years ago
Dupe of bug 65798


*** This bug has been marked as a duplicate of 65798 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.