AppSync UI needs polishing within the Dashboard

RESOLVED INVALID

Status

P3
normal
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: mdabbagh.mozilla, Assigned: ianbicking)

Tracking

Details

(Whiteboard: client)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
The AppSync UI within the Dashboard needs polishing. Currently, after the user signs in to BrowserID, some click-able text appears but that's about it. The formatting and placement is not correct either as the email gets cut-off if it's long enough.

This bug could be used to track UI discussions for AppSync if needed.

Steps to Reproduce:
1. Launch Firefox
2. Make sure to not have the apps extension installed or enabled - As of the date of this bug being filed, AppSync works only without the extension
3. Go to myapps.mozillalabs.com
4. Sign in to BrowserID - You'll need to create a BrowserID account at https://browserid.org/ if you don't already have one

Actual Result: 
Text appears stating 'Sync'. The UI is not very polished. 

Expected Results:
A polished UI with correct formatting is shown within the Dashboard.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 704277
(Assignee)

Updated

7 years ago
Blocks: 700492
Priority: -- → P1
Whiteboard: client
(Assignee)

Comment 3

7 years ago
deployed to myapps
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
Created attachment 578396 [details]
Screenshot
(Reporter)

Comment 5

7 years ago
There is still a bug where the BrowserID names are cut-off. Please see attachments for a screenshot.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → ianb
(Assignee)

Comment 6

7 years ago
I'm not sure what to do about name cutoffs.  It's kind of constrained to an absolute width, and there's no width where we can be sure the usernames will fit in.  I guess <span title="username">username</a> would make it possible, though I don't know any graceful way to do anything but truncate the username (e.g., it would be nice to have "somelonguser@dom..." but I don't know how to get those ellipsis in the right place).

Someone with better CSS-fu than I might have an idea.
(Assignee)

Updated

7 years ago
Priority: P1 → P3
(Reporter)

Comment 7

7 years ago
Maybe we can move the BrowserID sign-in button and the div related to Sync to the left a little closer to the Dashboard? Right now, it's far to the right and looks out of place. This way we don't have to do anything with the name and it will fully show up since there is more room now. Just a thought.
(Reporter)

Comment 8

7 years ago
Created attachment 579384 [details]
Screenshot of suggestion to move sync closer to Dashboard
Blocks: 710342
No longer blocks: 700492
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/24808907
The old app sync codebase is no longer going to be supported. Apps in the cloud will be under a different codebase. None of these bugs are valid anymore.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.