Add sort by Purchase Date to My Purchases page

VERIFIED FIXED in 6.3.4

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Cristian Boldan, Assigned: cvan)

Tracking

unspecified
6.3.4

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 576455 [details]
my purchases sorting filter

Steps to Reproduce:
1. Login to AMO apps page https://apps-preview-dev.allizom.org/en-US/apps/
2. Click on My Purchases link from the main menu
3. Verify the Sort by filters menu

Expected results:
Sort by "Purchased date" filter is present in the menu

Actual results:
User can only sort by "Price" or "Name"
(Assignee)

Comment 1

6 years ago
Per the mocks, the "Purchase Date" sort option is missing: https://people.mozilla.com/~fligtar/marketplace/My%20Purchases.png
Assignee: nobody → cwiemeersch
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Only 2 sort options in My Purchases Apps page → Add sort by Purchase Date to My Purchases page
Target Milestone: --- → 6.3.3

Comment 2

6 years ago
I removed it because I wasn't sure how to do it quickly with multiple purchases and refunds. So feel free to assign to me.
(Assignee)

Comment 3

6 years ago
https://github.com/mozilla/zamboni/commit/73a9c49
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 6.3.3 → 6.3.4
(Reporter)

Comment 4

6 years ago
Verified as fixed in https://apps-preview-dev.allizom.org/en-US/firefox/users/purchases/
Attaching postfix screenshot.
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

6 years ago
Created attachment 578586 [details]
postfix purchase date filter
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.