Runaway Memory Consumption (1GB+) (biff/mail notif set to 60)

VERIFIED DUPLICATE of bug 58721

Status

MailNews Core
Backend
--
critical
VERIFIED DUPLICATE of bug 58721
17 years ago
9 years ago

People

(Reporter: bobbyo, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

When mail is launched from the mozilla browser, the mail window appears but is
unresponsive to user input including mouse-overs and mouse clicks. All other
mozilla windows become unresponsive.
Mozilla begins consuming memory until the system runs out of virtual memory
(1GB+ on my machine) and I have to kill mozilla using the Task Manager.
Hence Mail becomes completely unusable.
The cause appears to be setting the mail server check time to 60 or 120 minutes

Reproducible: Always
Steps to Reproduce:
1.Launch Mozilla browser, click Tasks->Mail
2.From Mail, click Edit -> Mail/News Account Settings
3.From the Account Settings Dialog Box, Choose a Server
4.From Server Settings, Set 'Check for new Messages every [10] minutes' to
'...every [60] minutes'
5.Accept changes, close mozilla, restart mozilla, try to launch mail.

Actual Results:  Launching mail program makes mozilla consume system memory
without limit.
Mail program cannot be used. Mail cannot be accessed.

Expected Results:  Launched mail without consuming all system memory.

The problem can be corrected as a fix through hand-editing prefs.js as a text file.
(This is how I got my mail to work again.)
Simply delete the line(s) for
user_pref("mail.server.server3.check_time", 60);
in prefs.js <or> change the line to read 10 rather than 60.

Comment 1

17 years ago
This sounds awfully familiar -- maybe a duplicate, am looking for existing bug.
Summary: Runaway Memory Consumption (1GB+) → Runaway Memory Consumption (1GB+) (biff/mail notif set to 60)

Comment 2

17 years ago
This sounds awfully familiar -- maybe a duplicate, am looking for existing bug.
QA Contact: esther → sheelar

Comment 3

17 years ago
Doh. Duplicate of 58721.

*** This bug has been marked as a duplicate of 58721 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.