Session restore is blocked by the "Make default browser" modal dialog

RESOLVED DUPLICATE of bug 555529

Status

()

RESOLVED DUPLICATE of bug 555529
7 years ago
7 years ago

People

(Reporter: jaws, Unassigned)

Tracking

({ux-userfeedback})

Trunk
x86_64
Windows 7
ux-userfeedback
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression from bug 390060?)

This may be a regression from bug 390060.

When the browser starts up, if it is not the default browser then the "make default browser" modal dialog pops up. The session isn't restored until after a decision is made, and so it can confuse a user if they think that their session was lost because they reopened Firefox only to find that none of their tabs are there.
Well, if this is really an issue, I suppose bringing up the default browser dialog before bringing up the browser UI would be one possible approach here.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555529
You need to log in before you can comment on or make changes to this bug.