It's possible to scroll/pan the page out of view

VERIFIED FIXED

Status

()

Firefox for Android
General
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: Steffen Wilberg, Assigned: pcwalton)

Tracking

unspecified
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
http://hg.mozilla.org/projects/birch/rev/fec276ae77d5

I can pan the page out of view with these steps:
1. Open about:about
2. Zoom out until the horizontal scrollbar disappears
3. Reload (optional, but helps to reproduce)
4. Pan upwards or downwards

The page doesn't bounce at the boundaries, and it doesn't stop moving if most of it is already out of view..
If it is scrolled out of view to the top or bottom, you can't drag it back by panning in the opposite direction; you have to pan left or right, and it snaps back into view.

If you zoom out further, so that the vertical scrollbars disappear as well, you can pan the page out of view to the left or right. You then need to pan top or bottom to get it back.
This seems like a dupe of either bug 704950 or bug 698073
Assignee: nobody → kgupta
Created attachment 578253 [details]
screenshot of page scrolled off of the screen

I think that this is a separate issue. I can reproduce this issue without zooming the first time that I load http://nightly.mozilla.org. 

Flick the page down. It doesn't grab the top of the page each time back. After a few flicks the page is scrolled right off of the visible screen.

I can reproduce this issue on both my HTC Desire and Samsung Galaxy S II.
Also, I can do this with pages that have scroll bars visible and I can flick both up and down to make the page disappear.
I just checked and scrolling left and right also makes the page disappear off the visible screen. To summarize, I can make the page scroll off the screen in every direction.
(Reporter)

Comment 5

7 years ago
Created attachment 578358 [details]
screenshot

This is mostly fixed by bug 706615.

However, if I load about:about and zoom out further than the page width and height (bug 701594) and pan fast and dozens of times, I sometimes manage to move the page out of view, see the screenshot. Sometimes it just stays there, sometimes it snaps back after a couple of seconds.

Reloading now resets the zoom position.

Comment 6

7 years ago
Spoke on IRC, assigning this to Patrick.
Assignee: kgupta → pwalton
Things are much improved in the latest nightlies. However, I can still reproduce this issue, albeit with more difficulty.

Comment 8

7 years ago
This ought to be solved by bug #701594
Depends on: 701594

Comment 9

7 years ago
I'm marking this as fixed - there is still some strange-ish behaviour, but you can no longer do this. A separate bug can be filed with regards to that.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified fixed on:

Firefox 13.0a1 (2012-02-17)
20120217031227
http://hg.mozilla.org/mozilla-central/rev/2271cb92cc05

--
Device: Motorola Droid PRO
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
status-firefox13: --- → verified
You need to log in before you can comment on or make changes to this bug.