Last Comment Bug 704989 - add workaround for broken Outlook Web App (OWA) attachment handling
: add workaround for broken Outlook Web App (OWA) attachment handling
Status: VERIFIED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: unspecified
: All All
: -- major (vote)
: mozilla11
Assigned To: Julian Reschke
:
Mentors:
http://greenbytes.de/tech/tc2231/#att...
Depends on:
Blocks: 609667 692574
  Show dependency treegraph
 
Reported: 2011-11-23 14:33 PST by Julian Reschke
Modified: 2012-01-11 09:04 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
unaffected
+
fixed


Attachments
restore previous code, update test cases (3.74 KB, patch)
2011-11-24 04:33 PST, Julian Reschke
bzbarsky: review+
akeybl: approval‑mozilla‑aurora+
bzbarsky: checkin+
Details | Diff | Review
restore previous code, update test cases (3.74 KB, text/plain)
2011-11-24 10:21 PST, Julian Reschke
bzbarsky: review+
bzbarsky: checkin+
Details
Fx10beta3: Downloading attachment containing non-ASCII characters in file name (85.04 KB, image/png)
2012-01-11 01:12 PST, Andrea
no flags Details
Nightly12(x64): Downloading attachment containing non-ASCII characters in file name (62.09 KB, image/png)
2012-01-11 01:13 PST, Andrea
no flags Details

Description Julian Reschke 2011-11-23 14:33:57 PST
The fix for bug 692574 breaks Exchange 2010'S Outlook Web Access, which apparently sends header in the form:

Content-Disposition:attachment; filename*="Manuale%20installazione%20aggiornamento%20ORACOLO_BATCH%20V1.0.docx"

See also <https://bugzilla.mozilla.org/show_bug.cgi?id=703015#c32>.

We will need to back out the change for bug 692574 for now.
Comment 1 Julian Reschke 2011-11-24 02:11:57 PST
The same applies to bug 685192.
Comment 2 Julian Reschke 2011-11-24 04:33:32 PST
Created attachment 576723 [details] [diff] [review]
restore previous code, update test cases

This reverts the two code changes, but keeps the test cases, noting the changed results.
Comment 3 Julian Reschke 2011-11-24 04:34:18 PST
Comment on attachment 576723 [details] [diff] [review]
restore previous code, update test cases

(this change is for aurora)
Comment 4 Julian Reschke 2011-11-24 10:21:04 PST
Created attachment 576796 [details]
restore previous code, update test cases

patch for mozilla-central (same as aurora)
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-24 11:27:00 PST
Comment on attachment 576796 [details]
restore previous code, update test cases

r=me

We should probably reopen the bug we're backing out, right?
Comment 6 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-24 11:27:05 PST
Comment on attachment 576723 [details] [diff] [review]
restore previous code, update test cases

r=me
Comment 7 Julian Reschke 2011-11-24 11:46:25 PST
(In reply to Boris Zbarsky (:bz) from comment #5)
> We should probably reopen the bug we're backing out, right?

Will do.
Comment 8 Julian Reschke 2011-11-24 11:49:26 PST
Comment on attachment 576796 [details]
restore previous code, update test cases

Try results: https://tbpl.mozilla.org/?tree=Try&rev=9b8fe5daf2ac
Comment 9 Andrea 2011-11-24 13:24:13 PST
I confirm that try build https://tbpl.mozilla.org/?tree=Try&rev=9b8fe5daf2ac fixes it.
Comment 10 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-28 04:40:58 PST
http://hg.mozilla.org/mozilla-central/rev/e7dfdd9a119c
Comment 11 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-28 04:41:28 PST
Comment on attachment 576723 [details] [diff] [review]
restore previous code, update test cases

We should take this on beta too.
Comment 12 Julian Reschke 2011-11-28 04:45:43 PST
(In reply to Boris Zbarsky (:bz) from comment #11)
> Comment on attachment 576723 [details] [diff] [review] [diff] [details] [review]
> restore previous code, update test cases
> 
> We should take this on beta too.

Boris, it's not needed in Beta (these changes appeared in FF10 for the first time). Beta should be fine by now.
Comment 13 Julian Reschke 2011-11-28 04:46:56 PST
Comment on attachment 576723 [details] [diff] [review]
restore previous code, update test cases

(Removed approval-mozilla-beta request as this shouldn't affect FF9).
Comment 14 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-28 05:14:49 PST
> Boris, it's not needed in Beta

Ah, ok.  The tracking flags were just mis-set, arguably, and the status flags not set...
Comment 15 Alex Keybl [:akeybl] 2011-11-28 09:15:17 PST
Comment on attachment 576723 [details] [diff] [review]
restore previous code, update test cases

[Triage Comment]
Approving for Aurora - sorry about the confusion with FF9 tracking flags.
Comment 16 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-28 11:05:35 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/d1dd4b71c69e
Comment 17 Vlad [QA] 2012-01-09 05:22:45 PST
Hi guys.
Can you please tell me how can I test this feature?
Thanks
Comment 18 Julian Reschke 2012-01-09 05:32:26 PST
(In reply to Vlad [QA] from comment #17)
> Hi guys.
> Can you please tell me how can I test this feature?
> Thanks

You would need an Exchange installation with the current OWA (Outlook Web App) release.
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-09 15:18:41 PST
I don't think QA has access to this environment. Julian, would you be willing to verify the fix on Firefox 10?
Comment 20 Andrea 2012-01-09 15:31:08 PST
I have access to OWA 2010, so I could run some tests. What steps should I follow (test cases to run, fx version to use - is 10b3 ok?)?
Comment 21 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-09 15:42:03 PST
Julian can correct me if I am wrong, but I believe the same as you tested in bug 703015 comment 31, Andrea.
Comment 22 Julian Reschke 2012-01-10 00:32:49 PST
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #19)
> I don't think QA has access to this environment. Julian, would you be
> willing to verify the fix on Firefox 10?

I absolutely believe that OWA needs to be something QA can test regularly (I can't).

(In reply to Andrea from comment #20)
> I have access to OWA 2010, so I could run some tests. What steps should I
> follow (test cases to run, fx version to use - is 10b3 ok?)?

The test (and that test should be run for each Firefox release) is whether a download of a mail attachment with non-ASCII characters works properly.
Comment 23 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-10 07:28:00 PST
I've started an internal discussion about what QA can do in regards to future OWA testing. Andrea, any help you can provide in regard to this bug specifically would be greatly appreciated.
Comment 24 Andrea 2012-01-11 01:12:40 PST
Created attachment 587625 [details]
Fx10beta3: Downloading attachment containing non-ASCII characters in file name

With Fx beta3 (Built from http://hg.mozilla.org/releases/mozilla-beta/rev/e45fb547926c)
Comment 25 Andrea 2012-01-11 01:13:54 PST
Created attachment 587626 [details]
Nightly12(x64): Downloading attachment containing non-ASCII characters in file name

Nightly12 (x64) build of 2012-01-10 (Built from http://hg.mozilla.org/mozilla-central/rev/01d69766026d)
Comment 26 Andrea 2012-01-11 01:21:30 PST
Both download tests succeeded (10 beta3+nightly), file is downloaded with the correct name.

Also test:
http://greenbytes.de/tech/tc2231/#attwithfn2231quot

passed with the same builds of beta3 and nightly (for build info see attachment comments).

Since I have also access to another OWA mailbox that uses an older version (8.3.106.1), I've run the same download tests with the same builds as before and it passed with both of them.

Let me know if there are other tests to be run.

Note You need to log in before you can comment on or make changes to this bug.