Last Comment Bug 705001 - [New Tab Page] Spacing and thumbnail sizes should adapt to screen size
: [New Tab Page] Spacing and thumbnail sizes should adapt to screen size
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Tim Taubert [:ttaubert]
:
: Dão Gottwald [:dao]
Mentors:
: 721448 726105 (view as bug list)
Depends on: 729878
Blocks: 455553
  Show dependency treegraph
 
Reported: 2011-11-23 15:38 PST by Chris Lee [:clee]
Modified: 2012-03-28 07:18 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Chris Lee [:clee] 2011-11-23 15:38:45 PST
The spacing between thumbnails for the New Tab feature is too tight.  We should explore doubling the spacing between the thumbnails.  

Tim and I have talked about moving to a 4x2 grid vs. a 3x3 grid, but would like UX to weigh in on their thoughts.
Comment 1 User image Dão Gottwald [:dao] 2011-11-25 03:18:51 PST
Please take it to bug 455553, which hasn't landed on mozilla-central and is still under development.

*** This bug has been marked as a duplicate of bug 455553 ***
Comment 2 User image Chris Lee [:clee] 2011-11-28 13:11:37 PST
I spoke with Tim and we'd like to track changes to the original work separately so it's easier to manage.  Thanks.
Comment 3 User image Tiger.711 2011-12-01 06:18:19 PST
Why not allow the user to set the number of thumbnails? You can also resize previews as well as in the panorama.
Comment 4 User image Siddhartha Dugar [:sdrocking] 2011-12-01 07:34:41 PST
We can also resize groups in Panorama, and this can be applied to new tab page also. But why do we block the new tab page from landing from m-c for such cosmetic issues.
Comment 5 User image Chris Lee [:clee] 2011-12-01 10:53:18 PST
Tim's working on a few other fixes and needs his code reviewed before landing it on m-c.  This bug is by no means a blocker for nightly, but given the volume of how many new tabs are spawned per user per day, we want to get to a point where basic functionality was there and we could receive feedback.
Comment 6 User image Siddhartha Dugar [:sdrocking] 2011-12-03 23:03:32 PST
In addition, we should also have a boundary around thumbnails, currently it is not possible to distinguish thumbnails of pages having white background from the new tab background.
Comment 7 User image Alex Limi (:limi) — Firefox UX Team 2011-12-20 15:45:58 PST
3x3 grid is what we want, since humans in general work on a 7±2 item perception threshold. If people want infinite customizability here, they should get an add-on.

I do agree that the current visual setup isn't optimal, and the thumbnails should work better with wide or tall windows. Boriss will be your guide to the exact dimensions and spacing needed here.
Comment 8 User image Alex Limi (:limi) — Firefox UX Team 2011-12-20 15:48:02 PST
(In reply to Alex Limi (:limi) — Firefox UX Team from comment #7)
> 3x3 grid is what we want, since humans in general work on a 7±2 item
> perception threshold.

More info in case you're not familiar with this:
http://en.wikipedia.org/wiki/The_Magical_Number_Seven,_Plus_or_Minus_Two
Comment 9 User image Siddhartha Dugar [:sdrocking] 2012-01-20 00:23:26 PST
The thumbnail grid container has a fixed height which is larger than what is needed for the grid. So in a restored window a vertical scrollbar appears although there is enough room for the grid.
Comment 10 User image Paul [pwd] 2012-01-29 06:49:57 PST
The thumbnails are certainly too small on larger monitors, it simply leaves too much white-space.
Comment 11 User image Tim Taubert [:ttaubert] 2012-02-14 02:57:47 PST
*** Bug 721448 has been marked as a duplicate of this bug. ***
Comment 12 User image Tim Taubert [:ttaubert] 2012-02-23 06:34:20 PST
Will be fixed by bug 729878.
Comment 13 User image Tim Taubert [:ttaubert] 2012-03-13 03:41:00 PDT
Fixed by bug 729878.
Comment 14 User image Virgil Dicu [:virgil] [QA] 2012-03-14 05:41:07 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120313 Firefox/13.0a1

Marking this as verified. Checked on monitors with different screen sizes (17, 21,22 inch diagonal) on Mac OS 10.6, Ubuntu 11.10 and Windows 7. Thumbnails adapt to screen width.
Comment 15 User image Virgil Dicu [:virgil] [QA] 2012-03-28 07:18:39 PDT
*** Bug 726105 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.