Last Comment Bug 70509 - configure & configure.in changes required for Qt-Mozilla
: configure & configure.in changes required for Qt-Mozilla
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: John Griggs
: Jon Granrose
:
Mentors:
: 61760 (view as bug list)
Depends on:
Blocks: 70511 73987
  Show dependency treegraph
 
Reported: 2001-02-28 14:26 PST by John Griggs
Modified: 2004-11-22 17:25 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch for configure (281 bytes, patch)
2001-02-28 14:27 PST, John Griggs
no flags Details | Diff | Splinter Review
patch for configure.in (290 bytes, patch)
2001-02-28 14:28 PST, John Griggs
no flags Details | Diff | Splinter Review

Description John Griggs 2001-02-28 14:26:16 PST
The attached patches fix some problems with the Qt-Mozilla build:
- incorrect path for Qt include files
- Qt macro required to exclude Qt string processing stuff (qstrlen et al)

The patches were generated against the CVS tip revision as of Feb 28, 2001
Comment 1 John Griggs 2001-02-28 14:27:24 PST
Created attachment 26446 [details] [diff] [review]
Patch for configure
Comment 2 John Griggs 2001-02-28 14:28:08 PST
Created attachment 26447 [details] [diff] [review]
patch for configure.in
Comment 3 Daniel (Leaf) Nunes 2001-03-01 10:38:24 PST
r=leaf, cc'ing cls for sr.
Comment 4 cls 2001-03-01 11:01:24 PST
My only concern is that changing the include path may break builds made with
older versions of qt.  If you no longer support building with old versions of
qt, perhapps we should add a check.  Other than that, sr=cls.
Comment 5 Jon Granrose 2001-03-20 15:32:22 PST
*** Bug 61760 has been marked as a duplicate of this bug. ***
Comment 6 cls 2001-03-30 22:20:25 PST
Patch checked in. Marking fixed.
Comment 7 Jon Granrose 2001-05-07 15:22:02 PDT
verified.

Note You need to log in before you can comment on or make changes to this bug.