Last Comment Bug 705272 - [CC] Don't traverse the hidden window
: [CC] Don't traverse the hidden window
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks: 716598
  Show dependency treegraph
 
Reported: 2011-11-25 06:16 PST by Andrew McCreight [:mccr8]
Modified: 2012-01-09 10:42 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.39 KB, patch)
2011-11-25 07:12 PST, Olli Pettay [:smaug]
jst: review+
continuation: feedback+
Details | Diff | Splinter Review

Description Andrew McCreight [:mccr8] 2011-11-25 06:16:42 PST
It looks to me like the hidden window is created on startup, and lasts until shutdown.  Thus we should not traverse it.  This contains things (looks like maybe 500 DOM nodes?) and is traversed on OSX.  It contains things on Windows, even though it is a different type of document, but I don't know if it is really traversed there.  Hopefully this is doable by modifying nsCCUncollectableMarker.  I'm not sure why it isn't caught by that already.
Comment 1 Olli Pettay [:smaug] 2011-11-25 07:12:04 PST
Created attachment 576929 [details] [diff] [review]
patch

Does the patch help+
Comment 2 Andrew McCreight [:mccr8] 2011-11-25 07:43:29 PST
Comment on attachment 576929 [details] [diff] [review]
patch

This prevents the hidden window from being traversed, thanks!

Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=d1c5a9775853

It looked like that all documents were being traversed in the CC before the shutdown CC, which is odd, but I can't imagine this patch is at fault.  I'll have to keep an eye on that.
Comment 3 Olli Pettay [:smaug] 2011-11-29 11:14:03 PST
https://hg.mozilla.org/mozilla-central/rev/4c3b8d006a0d

Note You need to log in before you can comment on or make changes to this bug.