NS_ERROR_NOT_AVAILABLE in nsIHttpChannel.responseStatus

RESOLVED DUPLICATE of bug 704539

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 704539
7 years ago
6 years ago

People

(Reporter: Martin Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 576927 [details]
error-1322229494971.txt

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111115014305

Steps to reproduce:

Start Firefox.


Actual results:

Receive sync error almost immediately and the over and over again during browsing session. AFAIK there's no way to easily toggle syncing on and off. A Sync log showing an unexpected exception is attached.


Expected results:

No sync error message should have occurred. This seems to have started happening after I upgraded to 8.0.1
Component: General → General
Product: Firefox → Mozilla Services
QA Contact: general → general
Version: 8 Branch → unspecified
Martin: do you have a proxy PAC file ("automatic proxy configuration URL") set?

I believe this is Bug 690170, which is fixed in Firefox 10, but your symptoms seem slightly different.
Component: General → Firefox Sync: Backend
QA Contact: general → sync-backend
Summary: Initial and reoccurring Sync error on application startup → NS_ERROR_NOT_AVAILABLE in nsIHttpChannel.responseStatus
(Reporter)

Comment 2

7 years ago
Richard: I do have auto-detect network proxy settings enabled, but none should be found at this time.
(Reporter)

Comment 3

7 years ago
Addition information:

The initial error message:
> Sync encountered an error while connecting: Server incorrectly configured. Please try again.

is different from the one that follow:
> Sync encountered an error while synching: Unknown error. Sync will automatically retry this action.

Also there are different error logs produced each time a message is displayed. I will add a series of 4 of them, produced sequentially, beginning with startup.
(Reporter)

Comment 4

7 years ago
Created attachment 577111 [details]
1st in series of sequential error logs produced.

This corresponds to the initial "Server incorrectly configured" error message.
Attachment #576927 - Attachment is obsolete: true
(Reporter)

Comment 5

7 years ago
Created attachment 577113 [details]
2nd in series of sequential error logs produced
(Reporter)

Comment 6

7 years ago
Created attachment 577114 [details]
3rd in series of sequential error logs produced.
(Reporter)

Comment 7

7 years ago
Created attachment 577115 [details]
4th in series of sequential error logs produced.

Note that for some reason this log file is not plain text like the first 3 were.
(Reporter)

Comment 8

7 years ago
Comment on attachment 577115 [details]
4th in series of sequential error logs produced.

This error log is NOT plain/text -- or it's using some unknown encoding.
(In reply to Martin Miller from comment #3)
> The initial error message:> is different from the one that follow:

Yes, that's expected. Same error occurring in different places is deduced to have a different cause in each.

(In reply to Martin Miller from comment #2)
> Richard: I do have auto-detect network proxy settings enabled, but none
> should be found at this time.

OK, that confirms my hypothesis. Thanks.

If you give Aurora a try, I'm interested to see if the problem goes away.
Blocks: 690170
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 10

7 years ago
I was able to get the Sync errors to stop by changing my Network Connect settings to 'no proxy' from auto-detect -- which is fine because I'm not using one at this time.  Something that happens when auto-detection is on seems to be causing both the initial as well as the follow-on errors in different places.

I'll check out the situation with Aurora and report back.
(In reply to Martin Miller from comment #10)
> Something that happens when auto-detection is on
> seems to be causing both the initial as well as the follow-on errors in
> different places.

Yes, this problem is well-understood, and is fixed in Firefox 10, which is why I suggested you try Aurora.
(Reporter)

Comment 12

7 years ago
@Richard: It does not appear to be fixed in Aurora 10.0a2 (2011-11-27). What happens is a little different though. After turning auto detect proxy back on, the first error message is "Sync encountered an error while syncing: Unknown error" and the second was "Incorrect account name or password". Apparently sometimes an error doesn't produce an error message, only an error-*.log file.
I'll add a .zip archive with three consecutive error logs from Aurora in it, including the initial one. One of the following two did not cause an error message to display.
(Reporter)

Comment 13

7 years ago
Created attachment 577252 [details]
Error logs showing similar problem in Aurora 10.0a2
(Reporter)

Comment 14

7 years ago
Even with my network connection setting set to no proxy, I got a "Sync encountered an error while syncing: Unknown error" message. From the log it looks the cause is an exception in Sync.CollectionKeys: "TypeError: this[defer] is null" decrypting storage keys with sync key. I'll attach the complete error log, the file name is error-1322596954844.txt.

Question: Is this related to the original bug I reported or is it something different (and should be reported as such)?
(Reporter)

Comment 15

7 years ago
Created attachment 577931 [details]
Sync error with "no proxy" network connection setting.
(In reply to Martin Miller from comment #14)

> Question: Is this related to the original bug I reported or is it something
> different (and should be reported as such)?

Looks different; might be related. A new bug report would be great. Thanks!
This is possibly fixed in bug 690170 (Firefox 10). If not, it is almost certainly fixed in bug 704539 (Firefox 12).

If you still experience the issue after upgrading, please reopen this bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704539
You need to log in before you can comment on or make changes to this bug.