Regression in Kraken benchmark in todays (2011-11-25) Nightly build

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: blechri, Unassigned)

Tracking

11 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox11-)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:11.0a1) Gecko/20111125 Firefox/11.0a1
Build ID: 20111125033229



Actual results:

Regression in todays (2011-11-25) Nightly build (compared to 2011-11-23) in Kraken js benchmark. 4118.1ms +/- 0.4% ---> 4311.4ms +/- 0.5%
Main reason: desaturate: 293.7ms +/- 0.5% ---> 425.0ms +/- 6.2%
Full results: http://goo.gl/8lp72 (2011-11-23), http://goo.gl/wzEF7 (2011-11-25).
Restarted and reran the test with similar results. Before today the score has been below 4200 for the last tree weeks (at least).
(Reporter)

Updated

7 years ago
Component: General → JavaScript Engine
Product: Firefox → Core
(Reporter)

Updated

7 years ago
tracking-firefox11: --- → ?
(In reply to blechri from comment #0)
> User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:11.0a1)
> Gecko/20111125 Firefox/11.0a1
> Build ID: 20111125033229
> 
> 
> 
> Actual results:
> 
> Regression in todays (2011-11-25) Nightly build (compared to 2011-11-23) in
> Kraken js benchmark. 4118.1ms +/- 0.4% ---> 4311.4ms +/- 0.5%
> Main reason: desaturate: 293.7ms +/- 0.5% ---> 425.0ms +/- 6.2%
> Full results: http://goo.gl/8lp72 (2011-11-23), http://goo.gl/wzEF7
> (2011-11-25).
> Restarted and reran the test with similar results. Before today the score
> has been below 4200 for the last tree weeks (at least).

Would you mind retesting with a new nightly? I just tested 11-23 vs 11-28 and didn't get a regression for that pair, so I'm thinking it might have already been fixed.
(Reporter)

Comment 2

7 years ago
For me it still stands. With 11-28 I get very similar results: 4312.6ms +/- 0.7%. Full results here: http://goo.gl/GDtrV
I will update to todays build (11-29) and try again.
(Reporter)

Comment 3

7 years ago
Slightly better in todays build but not due to desaturation. 4291.9ms +/- 0.2%. Full results: http://goo.gl/tM0yu
(Reporter)

Comment 4

7 years ago
Haven't had the time to update until now. There has been a change between the 12-01 and the 12-04 build where the problem with desaturate have been solved, it now again lies around 290ms, but the general score for kraken is still higher than it was before the regression with 4273,2ms for the 12-04 build (4312 for the 12-01 build).

Another thing that happened between 12-01 and 12-04 is that sunspider regressed from 241,3ms to 296,4ms but I'll file a separate bug for that if I can't find any already up.

Not much has changed in the 12-05 and 12-06 builds.
(Reporter)

Comment 5

7 years ago
The sunspider regression was bug 707515
tracking-firefox11: ? → -

Comment 6

5 years ago
Not valid anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.