Import Settings and "Leave Messages on Server" is not selected

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: chuang)

Tracking

Trunk
mozilla0.9.1
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+] Have Fix)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Build 2001-02-26-09: NT4

Overview: Using Eudora, Outlook Express and Outlook I configured a POP account
and specifically selected the option to "Leave Messages on the Server". After
importing into Netscape6 I noticed that this setting is Not saved in the Account
Setting's Server panel.

Expected Results: I would expect the "Leave Messages on Server" option selected
since this setting was previously selected in Eudora, Outlook Express and Outlook.
(Reporter)

Comment 1

18 years ago
Marking nsbeta1 because a user may be surprised if they expect there messages to
remain on the server.
Keywords: nsbeta1
QA Contact: esther → nbaca

Comment 2

18 years ago
marking nsbeta1+ and moving to mozilla0.9
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9

Updated

18 years ago
Priority: -- → P2

Comment 3

18 years ago
reassigning to chuang.
Assignee: sspitzer → chuang
(Assignee)

Comment 4

18 years ago
reassign to Tony.
Assignee: chuang → tonyr

Comment 5

18 years ago
reassigning back to chuang. It was a miscommunication problem on my part.
Assignee: tonyr → chuang

Comment 6

18 years ago
moving to mozilla0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 7

17 years ago
I have the fix for Eudora on Win32.  However, there's an issue on Mac.  The
resource IDs we used to get the pop server name, user name, etc is different
between Eudora 5.0 and Eudora 5.1.   Are we going to support just 5.1?   I'm
fixing it based on 5.1.
Status: NEW → ASSIGNED

Comment 8

17 years ago
There's been a private email conversation on this so I'll add what was said in
it.  It sounds like we will support all versions of Windows Eudora.  My feeling
is that for the Mac, starting off with 5.1 is fine and we should open another
bug for supporting previous bersion.
(Assignee)

Comment 9

17 years ago
Created attachment 32881 [details] [diff] [review]
Patch for the fix
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta1+] → [nsbeta1+] Have Fix
(Assignee)

Comment 10

17 years ago
The fix is for Eudora on Mac and Win32,  Outlook and Outlook Express on Win32.
in EudoraMac, when you do stuff like that:
+
	GetIndString( pStr[0], resId /* 1000 */, 4);//	smtp server

can use use the constant (k...) instead of a numerical for the string index?
MacOS API use pascal string therfore the first byte in the string is the length
of the string and not the first characters. Also looks like to derefence the
string one level to much (*pStrs[n])[n]. Therefore the following line should not
works:
+        pop3Server->SetLeaveMessagesOnServer(*pStrs[kLeaveOnServerStr])[0] ==
'Y' ? PR_TRUE : PR_FALSE);

instead use:
+        pop3Server->SetLeaveMessagesOnServer(pStrs[kLeaveOnServerStr][1] == 'Y'
? PR_TRUE : PR_FALSE);

PS: I haven't tested it :-)
(Assignee)

Comment 13

17 years ago
Created attachment 32908 [details] [diff] [review]
A new patch with minor change on nsOESettings.cpp
(Assignee)

Comment 14

17 years ago
I'll change those numbers into constants.  The pStrs is a nsCString array and
has been assigned value from the Mac pascal string (code is in
nsEudoraMac::ImportSettings() and nsEudoraMac::GetSettingsFromResource()). 
"*pStrs[kLeaveOnServerStr])[0]"  has been tested and worked on Mac.

(Assignee)

Comment 15

17 years ago
Created attachment 32914 [details] [diff] [review]
New patch with constants
(Assignee)

Comment 16

17 years ago
Got r=ducarroz.

Comment 17

17 years ago
sr=mscott....looks good to me.

Comment 18

17 years ago
It looks like this got checked in so I'm marking fixed.  Please reopen if I'm
wrong about this.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Updated

17 years ago
Depends on: 78926
(Reporter)

Comment 19

17 years ago
Build 2001-05-16-04: WinMe/ Eudora 5.1, Outlook Express 5, Outlook 98: Fixed.

Question: I have configured Eudora on the Mac but when I import the settings
what file do I choose?
(Assignee)

Comment 20

17 years ago
If I remember correctly,  you choose "Eudora Setting".  I forgot where is this 
file.  If you can't find it.  I'll find it tomorrow when I'm in the office.
(Reporter)

Comment 21

17 years ago
Build 2001-05-17-08: Mac 9.04
Verified Fixed, but there is a problem with the UI in Account Settings.

After choosing the "Eudora Settings" file the folder pane displays an account 
called "Eudora Settings" with preset folders (Inbox, Drafts, Templates, Sent, 
Trash). After selecting the Inbox, I can get messages. The problem is in Account 
Settings because it does not display a "Server" and "Copies and Folders" panel. 
The settings appear more like "Local Folders" so it's difficult to confirm 
whether the "Leave Messages on Server" option is selected since the UI is not 
there.

The prefs.js file shows Leave Messages on Server pref is set to true 
{user_pref("mail.server.server1.leave_on_server", true);}. If I configure a new 
profile for the same mail account using the Account Wizard (qatest20), then the 
same messages are retrieved so it appears that the pref is working. 

For the above reasons I am verifying this bug. I will create a new bug for the 
UI problem especially since it is only a Mac problem.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 22

17 years ago
Note: Bug# 82019 covers the UI problem on the Mac.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.