Fennec crashes attempting to play radiognu.org

RESOLVED WORKSFORME

Status

()

P5
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: kats, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], URL)

Attachments

(1 attachment)

Created attachment 576975 [details]
Logcat output of crash

Load www.radiognu.org, click on the "normal" button in the RadioGNU widget on the right side of the screen, and try to play the radio stream. Observed behavior: Fennec quit back to the Android homescreen; expected behavior: no Fennec crash, hopefully music plays.

Logcat attached, indicates some sort of reflow error:
I/Gecko   (24858): ###!!! ABORT: must call nsHTMLReflowState& version during reflow: '!(f->GetStateBits() & NS_FRAME_IN_REFLOW)', file /Users/kats/zspace/birch/layout/base/nsLayoutUtils.cpp, line 4689

(Since I built locally on Mac OS X, it didn't have the crash reporter installed, but the build is from hg changeset 2aec00aaf211)

Updated

7 years ago
Severity: normal → critical
Keywords: crash
Hardware: All → ARM
Whiteboard: [native-crash]
I was not able to crash using a Desire S or HTC G2. Each played the content from the page for 5-10 minutes.
I was trying on the Galaxy Tab 3.1 and it still crashed with a build from today. It was also crashing on the Droid Pro when I first reported the issue but haven't tried it again on that device since then.
Priority: -- → P5
Working fine for me using a nightly: Acer 3.1 Tablet and Nexus One

Kats - can you check again?
Works now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.