using hardware volume keys which cause blur in full screen mode cancels full screen

RESOLVED DUPLICATE of bug 578265

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 578265
6 years ago
2 years ago

People

(Reporter: kinetik, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Using the hardware volume buttons on my W510 or Apple keyboard causes Firefox to cancel full screen.  Presumably this happens because the volume UI window steals focus, so this is may be Linux/GTK only.

FWIW, VLC's full screen is not cancelled when using the hardware volume keys.

Comment 1

6 years ago
This is just bug 704709, isn't it?
We don't think so. The only keys which cause full-screen exit now are ESC and F11, so Matthew's guessing that pressing the volume keys is causing the Firefox window to lose focus, which causes full-screen to exit.

Bug 704709 is about not showing the warning UI on volume-key presses which don't cause full-screen exit.
Summary: using hardware volume buttons in full screen mode cancels full screen → using hardware volume keys which cause blur in full screen mode cancels full screen
Is this not 578265?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578265
No longer blocks: 545812
You need to log in before you can comment on or make changes to this bug.