the main toolbar is cut off at the end of the "plus" new tab button

VERIFIED FIXED

Status

()

defect
P1
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: asa, Assigned: sriram)

Tracking

unspecified
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox11 verified, fennec11+)

Details

Attachments

(3 attachments)

The main toolbar curves down to one pixel height on the right side. It should continue to the full right of the screen and not be cut off between the new tab button and the menu button.
(In reply to Asa Dotzler [:asa] from comment #0)
> The main toolbar curves down to one pixel height on the right side. It
> should continue to the full right of the screen and not be cut off between
> the new tab button and the menu button.

Why? I think the current design tries to invoke a "tab" feel to the URL bar.
(In reply to Asa Dotzler [:asa] from comment #0)
> The main toolbar curves down to one pixel height on the right side. It
> should continue to the full right of the screen and not be cut off between
> the new tab button and the menu button.

Mark, I guess Asa is using a tablet or a Galaxy Nexus which show the menu button at the right side of the tabs button. In which case the curve does look cut off at the right side because it doesn't expand below the menu button. Setting a background image for the ActionBar that blends with the curve should fix that (if this is what design guys want).
Yeah Asa's right, it looks like the tab image is being cut off, and we are seeing an extra blue border underneath the menu button that shouldn't be there.

See the attached screenshot/mockup comparison
(In reply to Ian Barlow (:ibarlow) from comment #3)
> Created attachment 577247 [details]
> Mockup / Screenshot comparison
> 
> Yeah Asa's right, it looks like the tab image is being cut off, and we are
> seeing an extra blue border underneath the menu button that shouldn't be
> there.
> 
> See the attached screenshot/mockup comparison

Side note, your device screenshot looks like what I see on ICS; the URL bar look more inflated than it is on Gingerbread.
yeah, that too :)
Posted image tab strip cut off
Yes, I was looking at this on a tablet. This is a mock up of what I see since I can't figure out how to take a proper screenshot.
Open the Android Settings and select Screen then select Screenshot (capture screenshots by holding the recent Apps key)
Product: Fennec → Fennec Native
Version: Trunk → unspecified
Duplicate of this bug: 707936
Duplicate of this bug: 706853
Assignee: nobody → sriram
Priority: -- → P1
Posted patch PatchSplinter Review
This patch applies a background to the actionbar so that the blue bar is removed. The background extends to the menu button too.

I am waiting for UI specs to fix the same. This patches just fixes extending the background to the menu button.
Attachment #580140 - Flags: review?(mark.finkle)
Attachment #580140 - Flags: review?(mark.finkle) → review+
Blocks: 705678
https://hg.mozilla.org/mozilla-central/rev/ad40be58fa5b
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
tracking-fennec: --- → 11+
Verified fixed on Native Nightly 13.0a1 (2012-02-15)
                  Native Beta 11.0 (20120215185359)
Device: Samsung Galaxy Tab
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.