Filter rules are not correctly written in msgFilterRules.dat after modification

RESOLVED DUPLICATE of bug 606674

Status

RESOLVED DUPLICATE of bug 606674
7 years ago
7 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20111008085056

Steps to reproduce:

Create a filter rule with more than six conditions and choose "match any" (OR operation), and close close all filtering windows.
MsgFilterRules.dat is written correctly : all conditions are of type OR.
Modify the filter and select "match all" (AND operation), and close the windows again.
MsgFilterRules.dat is not correctly written : the six firsts conditions are now of type AND, but not the others.




Actual results:

In "msgFilterRules.dat" :

condition="AND (all addresses,contains,item1) AND (all addresses,contains,item2) AND (all addresses,contains,item3) AND (all addresses,contains,item4) AND (all addresses,contains,item5) AND (all addresses,contains,item6) OR (all addresses,contains,item7) OR (all addresses,contains,item8)


Expected results:

condition="AND (all addresses,contains,item1) AND (all addresses,contains,item2) AND (all addresses,contains,item3) AND (all addresses,contains,item4) AND (all addresses,contains,item5) AND (all addresses,contains,item6) AND (all addresses,contains,item7) AND (all addresses,contains,item8)

Comment 1

7 years ago
(In reply to bugzilla from comment #0)
So this is an issue with the front-end not updating the file. I'm not sure if the latest Thunderbird has this issue or not? Can you upgrade and check?

Comment 2

7 years ago
Thanks, this is already files as bug 606674.
Please move there and provide exact steps to reproduce this. Exact order of button presses, etc.
We haven't been able to reproduce this so far, maybe we are doing something wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606674
You need to log in before you can comment on or make changes to this bug.