Pages Generated using XSLT don't auto jump according to document.location.hash

RESOLVED DUPLICATE of bug 911122

Status

()

RESOLVED DUPLICATE of bug 911122
7 years ago
5 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111115183541

Steps to reproduce:

If you visit a URL of this format:

http://example.com/#loc

And some text/html is returned. It will automatically jump to the element on the page with an id of "loc".

If text/xml is returned, and client side XSLT is used to generate the HTML page, it *doesn't* dump to the element with id of "loc". If you click the address bar and hit return, it jumps. But it doesn't jump on page load.

Comment 1

5 years ago
Bug 911122 is newer, but it has a test case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911122
You need to log in before you can comment on or make changes to this bug.