Browser crash when coming out of sleep mode using Nightly

RESOLVED DUPLICATE of bug 705154

Status

()

--
critical
RESOLVED DUPLICATE of bug 705154
7 years ago
7 years ago

People

(Reporter: automatedtester, Unassigned)

Tracking

({crash, regression})

Trunk
x86_64
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
Nightly crashes when coming out of sleep mode. I just give the window focus and then try to use it and that is when it crashes. I have put about support details below. Let me know if you need anything else

#### about:support



  Application Basics

        Name
        Firefox

        Version
        11.0a1

        User Agent
        Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111126 Firefox/11.0a1

        Profile Directory

          Show in Finder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Firebug
        1.7.0
        true
        firebug@software.joehewitt.com

        Firefinder for Firebug
        1.01
        true
        firefinder@robertnyman.com

        Google Dictionary and Google Translate
        2.2
        true
        googledictionary@toptip.ca

        Selenium IDE: C# Formatters
        1.0.0
        true
        csharpformatters@seleniumhq.org

        Selenium IDE: Java Formatters
        1.0.0
        true
        javaformatters@seleniumhq.org

        Selenium IDE: Python Formatters
        1.0.0
        true
        pythonformatters@seleniumhq.org

        Selenium IDE: Ruby Formatters
        1.0.0
        true
        rubyformatters@seleniumhq.org

        Test Pilot
        1.2
        true
        testpilot@labs.mozilla.com

        YSlow
        2.1.0
        true
        yslow@yahoo-inc.com

        DivX Plus Web Player HTML5 <video>
        2.1.2.145
        false
        {23fcfd51-4958-4f00-80a3-ae97e717ed8b}

        Selenium IDE
        1.0.9
        false
        {a6fd85ed-e919-4a43-a5af-8da18bda539f}

        Selenium IDE: Groovy Formatters
        1.0.0
        false
        groovyformatters@seleniumhq.org

        Selenium IDE: Perl Formatter
        1.0.0
        false
        perlformatters@seleniumhq.org

        Selenium IDE: PHP Formatters
        1.0.0
        false
        phpformatters@seleniumhq.org

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.casesensitive
        1

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20111126031027

        browser.startup.homepage_override.mstone
        rv:11.0a1

        extensions.lastAppVersion
        11.0a1

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1321528011

        places.history.expiration.transient_current_max_pages
        104858

        places.history.expiration.transient_optimal_database_size
        167772160

        print.macosx.pagesetup-2
        PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…

        print.print_bgcolor
        false

        print.print_bgimages
        false

        print.print_command

        print.print_downloadfonts
        false

        print.print_evenpages
        true

        print.print_in_color
        true

        print.print_margin_bottom
        0.5

        print.print_margin_left
        0.5

        print.print_margin_right
        0.5

        print.print_margin_top
        0.5

        print.print_oddpages
        true

        print.print_orientation
        0

        print.print_page_delay
        50

        print.print_paper_data
        0

        print.print_paper_height
        11.00

        print.print_paper_size_type
        1

        print.print_paper_size_unit
        0

        print.print_paper_width
        8.50

        print.print_printer

        print.print_reversed
        false

        print.print_scaling
        1.00

        print.print_shrink_to_fit
        true

        print.print_to_file
        false

        print.print_unwriteable_margin_bottom
        57

        print.print_unwriteable_margin_left
        25

        print.print_unwriteable_margin_right
        25

        print.print_unwriteable_margin_top
        25

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        security.disable_button.openCertManager
        false

        security.warn_viewing_mixed
        false

  Graphics

        Vendor ID
        10de

        Device ID
        0a29

        WebGL Renderer
        NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-1.6.40

        GPU Accelerated Windows
        2/2 OpenGL

        AzureBackend
        skia

Updated

7 years ago
Keywords: crash

Comment 1

7 years ago
The stack trace in thread 0 look like:
Frame 	Module 	Signature [Expand] 	Source
0 	AppKit 	+[NSEvent otherEventWithType:location:modifierFlags:timestamp:windowNumber:context:subtype:data1:data2:] 	
1 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:443
2 	CoreFoundation 	CoreFoundation@0x4e3d0 	
3 	CoreFoundation 	CoreFoundation@0x4c5c8 	
4 	libmozutils.dylib 	je_malloc 	memory/jemalloc/jemalloc.c:1596
5 	CoreFoundation 	CoreFoundation@0x65f1 	
6 	CoreFoundation 	CoreFoundation@0xec44
Blocks: 429592
Severity: normal → critical
Crash Signature: chromehang | +[NSEvent otherEventWithType:location:modifierFlags:timestamp:windowNumber:context:subtype:data1:data2:] → [@ chromehang | +[NSEvent otherEventWithType:location:modifierFlags:timestamp:windowNumber:context:subtype:data1:data2:] ]
Component: General → Widget: Cocoa
Keywords: regression
Product: Firefox → Core
QA Contact: general → cocoa
Hardware: x86 → x86_64
Version: unspecified → Trunk

Comment 2

7 years ago
Any mac-specific "chromehang" bugs should currently be duped to bug 705154.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705154
You need to log in before you can comment on or make changes to this bug.