control-z does not work using linux Awesome WM

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: L.I.A.R., Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I'm using swapcaps (setxkbmap -option ctrl:swapcaps)

When editing any text field (e.g., email body or subject) when I use control-x to cut text, it works (as well as control-a/e/arrows, etc.), but when I then use control-z to undo my cut, it does nothing. However, the menu entry "Edit -> Undo" (which is said to be linked to Ctrl-Z) works...

See also my entry for firefox: https://bugzilla.mozilla.org/show_bug.cgi?id=705527 and its second comment. However, in thunderbird, switching the window does not seem to make the undo action occur...

Comment 1

6 years ago
(In reply to L.I.A.R. from comment #0)
Just a small test: can you try CTRL-Z in another application, such as any text editor?
(Reporter)

Comment 2

6 years ago
Already tested... It works perfectly with Xterm and GEdit for instance.
(Reporter)

Comment 3

6 years ago
Already tested... It works perfectly with Xterm and GEdit for instance.

Also for your information I'm using Awesome WM: awesome v3.4.9 (Smack)

Comment 4

2 years ago
Landry, does this also fail fo ryou?
Flags: needinfo?(landry)
See Also: → bug 705527
Using the same STR (enter text in subject/to/body, select part of text, cut with ctrl-x), ctrl-z correctly readds text just cut, so works for me using 38.4.0 on OpenBSD/amd64.

Should note that i use a sun keyboard with ctrl and caps physically swapped, so i also use swapcaps:
$setxkbmap -print|grep symb 
        xkb_symbols   { include "pc+us+inet(pc105)+terminate(ctrl_alt_bksp)+ctrl(swapcaps)+compose(menu)"       };
Flags: needinfo?(landry)

Comment 6

2 years ago
(In reply to Landry Breuil (:gaston) from comment #5)
> Using the same STR (enter text in subject/to/body, select part of text, cut
> with ctrl-x), ctrl-z correctly readds text just cut, so works for me using
> 38.4.0 on OpenBSD/amd64.
> 
> Should note that i use a sun keyboard with ctrl and caps physically swapped,
> so i also use swapcaps:
> $setxkbmap -print|grep symb 
>         xkb_symbols   { include
> "pc+us+inet(pc105)+terminate(ctrl_alt_bksp)+ctrl(swapcaps)+compose(menu)"   
> };

L.I.A.R., 
Is your problem related to bug 705527?
Do you agree this now works (as suggested by gaston)?
Flags: needinfo?(sexxxenator)
Summary: control-z does not work → control-z does not work using linux Awesome WM
Whiteboard: [closeme 20156-01-15]

Comment 7

2 years ago
WFM per comment 5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sexxxenator)
Resolution: --- → WORKSFORME
Whiteboard: [closeme 20156-01-15]
You need to log in before you can comment on or make changes to this bug.