"Not available for Firefox Latest-n.x" shown although addon is actually available

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: haqer, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

Visit, for instance, 
https://addons.mozilla.org/en-US/firefox/addon/image-assistant/
using Firefox 7.


Actual results:

"Not available for Firefox 7.0.1"


Expected results:

It has a prior version available for 7.*. "Not available" treatment shouldn't be based on the last version alone, and should only be shown if there are no compatible versions (possibly limiting to checking a few recent versions if needed).
I think this is correct behavior within our current definitions - Jorge?
If it were up to me, we would offer whatever version best fits the browser the visitor is using, but I believe this could make the code more difficult to maintain. If there are higher level priorities to push users to newer versions, fligtar would know about those, not me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

7 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> If it were up to me, we would offer whatever version best fits the browser
> the visitor is using, but I believe this could make the code more difficult
> to maintain.
I think it's clear cut: there's a version available for Firefox 7.0.1, but AMO says addon isn't available for Firefox 7.0.1. AMO disinforms the user, and prevents usage of the addon. That's a bug: it's not grey, it's black.

And the code is simple either way: pseudocode is instead of 
 {minVersion, maxVersion} = getMinMaxOfLastVersion();
 available = minVersion<= version && version<=maxVersion;
it'd be something like:
 availableVersion = findLatestAvailableVersion(version);
 available = availableVersion != null;

P.S. I also believe this is a regression bug: it used to work right, and got broken fairly recently.
(Reporter)

Comment 4

7 years ago
Here's another illustration of the problem:
https://addons.mozilla.org/en-US/firefox/addon/QIRIMTATARCA-til-destesi

The addon has been reviewed prior to 9.0 release: this is a good thing, but AMO is saying the addon is not available for Firefox 8.0, which is ridiculous, because it is.

Comment 5

7 years ago
AFAICT this is hitting Lightning currently, which is a key Thunderbird addon. TB is at 9.01, Lightning has now released their next version which is compatible with 10.0 - 10.*

Users are leaving 1 star reviews because Lightning is not compatible with the current TB release, even though the previous release supports it.

Comment 6

7 years ago
This takes new precedence with the ESR versions of Firefox, which always will have an out-of-date version number. Right now, using the ESR version, the above examples show "Not available for Firefox 10.0.3"
Would this be related to bug 733080? It sounds like once that's in place, many of these problems will go away.

Comment 8

7 years ago
Bug 733080 may (or may not) be fixed in some version of some Mozilla product (looks like Firefox), but NOT in Thunderbird ESR 10.

It appears literally impossible to install Lightning in ESR (which "is intended for groups ... in large organizations such as universities and other schools, county or city governments and businesses" - the very folks who are most likely to want and need calendaring support), except via manual download and install.

I've spent the past several days (since downgrading to the ESR release to get off of the wild version merry-go-round) believing that Mozilla was refusing to support Lightning on their ESR versions -- all because the UI refuses to do so.

To install Lightning in ESR, I had to:

1) find this bug report to even understand why T-bird ESR 10 insists that Lightning is incompatible with T-bird;

2) guess at the add-ons URL (OK, could have found it with some looking):
https://addons.mozilla.org/

3) understand that Firefox was refusing to find any pages for Lightning because it's filtering for apps compatible only with itself;

4) manually change the URL in Firefox to pull up add-ons for T-bird:
https://addons.mozilla.org/en-US/thunderbird;

5) ignore the big, bold red warning "BE CAREFUL WITH OLD VERSIONS!";

6) search for the newest version compatible with T-bird ESR 10 (v. 1.2.3 as of this time);

7) manually download the .xpi file;

8) load T-bird, open Add-Ons Manager, find the non-intuitively placed "Install Add-ons from file" from the cryptic settings button; and 

9) browse to the Firefox download folder, find the file, and select to install.

I've managed to get Lightning working in T-bird ESR 10; but doing so is -- shall we say -- non-intuitive.

Unless this fix is back-ported, other less technical users are likely to give up and figure that Mozilla has dumped big organization and only supports bleeding edge users.

May I suggest that some page be added to the Add-on Manager search result (maybe by creating a dummy "Lightning Older Version Add-on for ESR" with instructions and links for installing Lightning on ESR)?
Duplicate of this bug: 873696
Duplicate of this bug: 835097

Comment 11

5 years ago
I'm using 24ESR and wanted to install https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/versions/

But it says "Not available for Firefox 24.0".

In the "Versions"-page, there's a version listed for 24ESR, so the initial message is a lie.

But who of the hundreds of millions of novice users know about "Versions"?
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.