Last Comment Bug 705590 - measure system font fallback times and other cases where fonts are enumerated
: measure system font fallback times and other cases where fonts are enumerated
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: John Daggett (:jtd)
:
Mentors:
Depends on:
Blocks: 705258
  Show dependency treegraph
 
Reported: 2011-11-27 19:53 PST by John Daggett (:jtd)
Modified: 2011-11-30 03:58 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch, add in timing of system font fallback (2.88 KB, patch)
2011-11-28 23:56 PST, John Daggett (:jtd)
jmuizelaar: review+
Details | Diff | Review

Description John Daggett (:jtd) 2011-11-27 19:53:21 PST
In some situations font code is now forced to iterate over all fonts in the system, to find a font for a given character, or to look up a localized font name.  The chromehang patch (bug 429592) appears to be seeing hangs in GetFontData, one of the routines called when system font fallback occurs (bug 705258).  Essentially this is inferring that iterating over fonts takes >30 secs for some users.

To verify this, we should instrument the system font fallback code and the other names code with telemetry probes to tell us what the histogram of response times are.
Comment 1 John Daggett (:jtd) 2011-11-28 23:56:35 PST
Created attachment 577513 [details] [diff] [review]
patch, add in timing of system font fallback

This adds two histograms for measuring system font fallback timing.  The first time is separated out because the first time cmaps are pulled in if not already cached.
Comment 2 John Daggett (:jtd) 2011-11-29 18:20:25 PST
Landed on mozilla-inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/a36ee10d4f5d
Comment 3 Marco Bonardo [::mak] 2011-11-30 03:58:34 PST
https://hg.mozilla.org/mozilla-central/rev/a36ee10d4f5d

Note You need to log in before you can comment on or make changes to this bug.