Profile Reviews are missing---GONE!!!!

RESOLVED FIXED in 6.3.6

Status

P1
major
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: smayer97, Assigned: kumar)

Tracking

unspecified
6.3.6

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.24) Gecko/20111103 Firefox/3.6.24
Build ID: 20111103063747

Steps to reproduce:

Viewed my profile reviews. 

Checked some of add-ons I reviewed.


Actual results:

Most of the dozens and dozens and dozens of reviews I have written are missing!!!!! Only 6 remain.

Did not find reviews under my profile or under some of the add-ons.


Expected results:

Should have seen list of dozens and dozens and dozens of my reviews. 

Should have found my reviews under the add-ons.
(Reporter)

Comment 1

7 years ago
my user id is smayer97
Severity: normal → major

Comment 2

7 years ago
(In reply to smayer97 from comment #0)
> Steps to reproduce:
> Viewed my profile reviews. 

Which URL would that be, to reproduce the problem?
(Reporter)

Comment 3

7 years ago
my profile page @  https://addons.mozilla.org/en-US/firefox/user/2735762/

example add-on missing my reviews @ https://addons.mozilla.org/en-US/firefox/addon/find-in-tabs/reviews/

If you search for smayer97 in the reviews you will see other reviews that refer to MY review BUT all my reviews for this add-on are GONE (I wrote at least 2 reviews (I think it may have been 3 or 4) for this add-on alone)!!!

I have written MANY MANY reviews for LOTS of add-ons...Only 6 show up in my profile or anywhere now.
There are only 6 reviews from you in the database.  I can confirm that you had 58 reviews in the past and there isn't anything that jumped out at me in the logs.  I haven't investigated further.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

7 years ago
Great for confirming...SO, how did you confirm that I had 58 reviews? And where are the 58 that you were able to find?
I looked in a database dump from 2011-11-27 in the morning and you had 65 reviews.  Sometime between then and when you filed this bug that night the reviews went missing.

Kumar: can you see if you can tell what happened?
Assignee: nobody → kumar.mcmillan
Severity: major → normal
Priority: -- → P3
Target Milestone: --- → 6.3.3
(In reply to Wil Clouser [:clouserw] from comment #6)
> I looked in a database dump from 2011-11-27 in the morning and you had 65
> reviews.  Sometime between then and when you filed this bug that night the
> reviews went missing.

This may not be accurate.
(Reporter)

Comment 8

7 years ago
What part may not be accurate? The timing or the amount of content missing or the source used?

BTW, I have seen comments in reviews from others, as far back as Nov 1 (so far), that seem to have the same problem.
Severity: normal → major
Target Milestone: 6.3.3 → 6.3.4
Target Milestone: 6.3.4 → 6.3.5
(Reporter)

Comment 9

7 years ago
Please clarify what this all means by changing the target milestone

Also, can I add new reviews or will this impede the resolution of this problem? or worse, cause me to lose any new reviews I add? Please advise
(Reporter)

Comment 10

7 years ago
I really need the reviews to help guide my activities regarding addons (I manage hundreds of add-ons and collections and provide a lot of feedback)

Comment 11

7 years ago
(In reply to smayer97 from comment #9)
> Please clarify what this all means by changing the target milestone

See https://bugzilla.mozilla.org/page.cgi?id=fields.html#target_milestone (which is also the link right next to the field): "The Target Milestone field is used to define when the engineer [...] expects to fix it." That's all.
(Reporter)

Comment 12

7 years ago
Thanks....Is there a timeline associated with the milestone?

Also, can I still add more reviews or will that complicate things?
Duplicate of this bug: 705372
I'm still investigating this issue. It appears that 1,367 reviews are missing.
Priority: P3 → P1
Target Milestone: 6.3.5 → 6.3.6
We were able to restore the missing reviews. The fix went into production on 12/29/2011 in bug 713667

According to our backup, we were missing 1500 reviews. 656 of those were valid reviews (i.e. ones whose version had not since been deleted).  We were able to recover 630 of those because the rest were missing translation strings.

Unfortunately, we're still unclear on the root cause so please let us know if this happens again. Sorry for the inconvenience and thanks for your patience.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Created attachment 585875 [details]
user IDs for which missing reviews were restored
Created attachment 585876 [details]
version IDs for which reviews were restored
(Reporter)

Comment 18

7 years ago
Thanks for fixing.
BTW, I see that I have about 10 duplicate reviews. Not sure if these were there before (they may have due to a bug that sometimes would not show the first posting right away). Is there a way to clean this up?
I looked at the dupes on your review page. Some have the same message but are for different add-ons. I do see duplicate reviews for the same addon but they look legitimate in the database. They were submitted sequentially within about 20 seconds of each other so, yeah, maybe it was the display issue you mentioned. I'd suggest deleting the duplicates by hand since you'll know better than I which one you want to keep.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.