crash in mozilla::scache::StartupCache::GetBuffer @ PL_DHashTableOperate

RESOLVED DUPLICATE of bug 700493

Status

()

Core
Networking
--
critical
RESOLVED DUPLICATE of bug 700493
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({crash})

Trunk
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
I got this crash while restarting from Firefox 8beta, updating to Firefox9beta and then restarting.

This bug was filed from the Socorro interface and is 
report bp-03c45002-c04a-4eca-8eb6-2bc312111127 .
============================================================= 
0 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.cpp:615
1 	xul.dll 	mozilla::scache::StartupCache::GetBuffer 	startupcache/StartupCache.cpp:238
2 	xul.dll 	nsXULPrototypeCache::HasData 	content/xul/document/src/nsXULPrototypeCache.cpp:545
3 	xul.dll 	nsXULPrototypeScript::SerializeOutOfLine 	content/xul/content/src/nsXULElement.cpp:2972
4 	xul.dll 	nsXULDocument::OnStreamComplete 	content/xul/document/src/nsXULDocument.cpp:3585
5 	xul.dll 	nsStreamLoader::OnStopRequest 	netwerk/base/src/nsStreamLoader.cpp:125
6 	xul.dll 	nsJARChannel::OnStopRequest 	modules/libjar/nsJARChannel.cpp:924
7 	xul.dll 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:578
8 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:403
9 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
10 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
11 	xul.dll 	nsThread::GetObserver 	xpcom/threads/nsThread.cpp:705
12 	xul.dll 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:494
13 	xul.dll 	nsThreadPool::Shutdown 	xpcom/threads/nsThreadPool.cpp:299
14 	xul.dll 	nsStreamTransportService::Observe 	netwerk/base/src/nsStreamTransportService.cpp:545
15 	xul.dll 	nsObserverList::NotifyObservers 	xpcom/ds/nsObserverList.cpp:130
16 	xul.dll 	nsObserverService::NotifyObservers 	xpcom/ds/nsObserverService.cpp:182
17 	xul.dll 	mozilla::ShutdownXPCOM 	xpcom/build/nsXPComInit.cpp:607
18 	xul.dll 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1084
19 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3587
20 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Resolution: --- → DUPLICATE
Summary: crash [ @ PL_DHashTableOperate] → crash in mozilla::scache::StartupCache::GetBuffer @ PL_DHashTableOperate
Duplicate of bug: 700493
You need to log in before you can comment on or make changes to this bug.