Closed Bug 705930 Opened 10 years ago Closed 10 years ago

Thank you page for mobile

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: krupa.mozbugs, Assigned: potch)

References

Details

The post-purchase thank you modal/screen looks clunky in an Android device. Please see if we can make this better.
can you be more specific?  I don't know what "clunky" is but I'll assume it's a low priority.
Priority: -- → P3
The issue is it's the desktop version.
Target Milestone: --- → 6.3.4
Target Milestone: 6.3.4 → 6.3.5
This raises an interesting issue with pre-approvals which don't even bounce through to paypal. So we'll probably just have to redirect to the mobile thank you page that we set up for this. I'll file an issue dependent upon whatever happens here.
Blocks: 712690
Target Milestone: 6.3.5 → 6.3.6
Blocks: 710074
No longer blocks: 690899
Target Milestone: 6.3.6 → 6.3.7
Blocks: 718560
No longer blocks: 710074
Target Milestone: 6.3.7 → 6.3.8
Target Milestone: 6.3.8 → ---
Target Milestone: --- → 6.4.0
When mobile payment happens paypal opens up a different window and does everything in there. At the end it opens up a page on AMO. On desktop that pages job is to close itself and show the modal dialog. 

Ideally: we'd do the same on mobile. Because of JS permissions fun I don't know if this is feasible. Potch can probably tell us if this is possible or practical.

If it's not: let's move most of the information from the modal dialog into this thank you page. The end user can see all the relevant information, install the app and click to return to the app.
Are we still doing this?
We'll resume this when we have UX guidance here.
Target Milestone: 6.4.0 → ---
do we still need UX here or is this solved with new pages?
Blocks: 735054
No longer blocks: 718560
Summary: Thank you modal for mobile → Thank you page for mobile
Target Milestone: --- → 6.4.8
This is no longer an issue with the new pages!
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
(In reply to Potch [:potch] from comment #8)
> This is no longer an issue with the new pages!

I thought it still was because the PayPal purchase flow starts in a new tab/window.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.