Upload to AMO throws client and server errors when run

RESOLVED FIXED in Builder 1.0

Status

P1
critical
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: dbuchner, Assigned: zalun)

Tracking

unspecified
Builder 1.0

Details

(Reporter)

Description

7 years ago
I am seeing the following errors when trying to upload an addon to AMO from -dev:

client JS error:

status_el.getElements(className)[0] is undefined
[Break On This Error] status_el.getElements(clas...[0].set('text', content).highlight();
Flight...tils.js (line 8)

---

Server 500 error:

500 INTERNAL SERVER ERROR
		249ms	
"NetworkError: 500 INTERNAL SERVER ERROR - https://builder-addons-dev.allizom.org/amo/addon_details/128993/"
(Reporter)

Updated

7 years ago
Assignee: nobody → zaloon
Priority: -- → P1
Target Milestone: --- → Builder 1.0
(Reporter)

Comment 1

7 years ago
The following traceback was sent as a result of this upload-to-AMO attempt: 

File "/data/www/builder-addons-dev.allizom.org/flightdeck/vendor/lib/python/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/builder-addons-dev.allizom.org/flightdeck/apps/amo/views.py", line 116, in get_addon_details
   'get_addon_info_url': revision.get_addon_info_url(),

AttributeError: 'PackageRevision' object has no attribute 'get_addon_info_url'
(Assignee)

Comment 2

7 years ago
Fixed before seen this bug request
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.