Last Comment Bug 706033 - Chrome migrator should notify of Migration:ItemError when there are errors
: Chrome migrator should notify of Migration:ItemError when there are errors
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Matthew N. [:MattN] (In Taipei until Sep. 23)
:
:
Mentors:
Depends on:
Blocks: 505192
  Show dependency treegraph
 
Reported: 2011-11-29 02:16 PST by Matthew N. [:MattN] (In Taipei until Sep. 23)
Modified: 2011-12-02 03:28 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0.1 Notify on error for cookies, history & bookmarks (2.53 KB, patch)
2011-11-29 02:16 PST, Matthew N. [:MattN] (In Taipei until Sep. 23)
mak77: review+
Details | Diff | Splinter Review

Description Matthew N. [:MattN] (In Taipei until Sep. 23) 2011-11-29 02:16:35 PST
Created attachment 577530 [details] [diff] [review]
v0.1 Notify on error for cookies, history & bookmarks

The migrator should notify of "Migration:ItemError" when there is an error migrating a specific item.  This is for consistency with the other migrators.
Comment 1 Marco Bonardo [::mak] 2011-11-29 03:50:41 PST
Comment on attachment 577530 [details] [diff] [review]
v0.1 Notify on error for cookies, history & bookmarks

Review of attachment 577530 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/migration/src/ChromeProfileMigrator.js
@@ +153,5 @@
> +   * Notify observers that a migration error occured with an item
> +   *
> +   * @param   aType
> +   *          notification type such as MIGRATE_BOOKMARKS
> +   */

sigh, javadocs should begin with /** looks like a global nit for all the migrator, I thought I commented about this in the original bug...
Comment 2 Matthew N. [:MattN] (In Taipei until Sep. 23) 2011-12-01 21:59:38 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a5a28f62c4d
Comment 3 Marco Bonardo [::mak] 2011-12-02 03:28:00 PST
https://hg.mozilla.org/mozilla-central/rev/2a5a28f62c4d

Note You need to log in before you can comment on or make changes to this bug.