Using F3 to "find again", auto-scroll needs tuning

RESOLVED DUPLICATE of bug 171237

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 171237
6 years ago
6 years ago

People

(Reporter: Pgr, Unassigned)

Tracking

5 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Used "Find" inside a Web page, any long page. Then pressed F3 to "Find again" the same term.

(a good place to test is searching for "Programming" in this page: http://ocw.mit.edu/courses/electrical-engineering-and-computer-science/ )


Actual results:

Firefox politely auto-scrolled down the page to show me the next occurrence of my search term.

This scroll happens so that the term shows at the very bottom of my window.


Expected results:

a) It would look better for readability if one or two additional lines were shown below my term (that is, if FF had scrolled a bit more).

b) For a specific case where the search text is found inside a link, it actually _needs_ to scroll a few extra lines or else the text will be hidden behind the "tooltip" that appears on the bottom line showing the link target (the test suggested above shows this nuisance). Notice that current window size and the length of the link target will determine whether text will actually be hidden behind the tooltip. But it would be a good idea to prevent this possibility altogether.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 171237
You need to log in before you can comment on or make changes to this bug.