Closed Bug 706282 Opened 8 years ago Closed 6 years ago

Intermittent Rev4 OS X64 TEST-UNEXPECTED-FAIL | /tests/dom/plugins/test/test_npruntime_npninvokedefault.html | application timed out after 330 seconds with no output

Categories

(Core :: Plug-ins, defect)

11 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mbrubeck, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [test which aborts the suite])

The screenshot shows the mochitest window with a "Connecting..." throbber, and "waiting for mochi.test" in the status bar.

https://tbpl.mozilla.org/php/getParsedLog.php?id=7638756&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitests-2/5 on 2011-11-29 11:41:53 PST for push b10b930500f1

5817 INFO TEST-PASS | /tests/dom/plugins/test/test_npruntime_npninvoke.html | npnInvokeTestFailed: pass - true should equal true
5818 INFO TEST-PASS | /tests/dom/plugins/test/test_npruntime_npninvoke.html | npnInvokeTestFailed: pass - true should equal true
5819 INFO TEST-PASS | /tests/dom/plugins/test/test_npruntime_npninvoke.html | npnInvokeTestFailed: pass - true should equal true
NPP_Destroy
5820 INFO TEST-END | /tests/dom/plugins/test/test_npruntime_npninvoke.html | finished in 202ms
5821 INFO TEST-START | /tests/dom/plugins/test/test_npruntime_npninvokedefault.html
TEST-UNEXPECTED-FAIL | /tests/dom/plugins/test/test_npruntime_npninvokedefault.html | application timed out after 330 seconds with no output
args: ['/usr/sbin/screencapture', '-C', '-x', '-t', 'png', '/var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/mozilla-test-fail_oei2yU']

Can't trigger Breakpad, just killing process
INFO | automation.py | Application ran for: 0:07:29.237126
INFO | automation.py | Reading PID log: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpH_OHOXpidlog
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
program finished with exit code 247
elapsedTime=452.339568
TinderboxPrint: mochitest-plain-2<br/><em class="testfail">T-FAIL</em>
Unknown Error: command finished with exit code: 247
======== Finished 'python mochitest/runtests.py ...' warnings (results: 1, elapsed: 8 mins, 16 secs) ========
OS: Linux → Mac OS X
Hardware: x86 → x86_64
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange][test which aborts the suite] → [test which aborts the suite]
https://tbpl.mozilla.org/php/getParsedLog.php?id=19636434&tree=Try#error0
Rev4 MacOSX Lion 10.7 try opt test mochitest-3 on 2013-02-11 09:40:48 PST for push e3e81daad3ee

slave: talos-r4-lion-052

The screenshot shows a Bluetooth Keyboard Setup dialog.  Problem with the slave?
(In reply to Matt Brubeck (:mbrubeck) from comment #3) 
> The screenshot shows a Bluetooth Keyboard Setup dialog.  Problem with the
> slave?

No, that's expected.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(OrangeWFM for bugs not modified in > 2 months)
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.