@bitvals array in editgroups.cgi contains errors

RESOLVED DUPLICATE of bug 47561

Status

()

RESOLVED DUPLICATE of bug 47561
18 years ago
6 years ago

People

(Reporter: kebneter, Assigned: justdave)

Tracking

Details

(Reporter)

Description

18 years ago
The file editgroups.cgi defines an array named @bitvals that contains a table of 
numbers used to generate the bit values for the 64-bit number that is used as a 
mask for group identification. The numbers in the array are the decimal values 
of the powers of two from 2^0 to 2^62. (This whole thing is a hack, but it's not 
my hack.) Unfortunately, several of the values in the array are wrong, which 
causes problems when you're creating groups. Specifically, the value 65535 is 
(fairly obviously) incorrect (should be 65536); also incorrect are the last two 
values in the array (spaces added for clarity): 

2 305 843 009 213 693 958 ==> 2 305 843 009 213 693 952
4 611 686 018 427 387 916 ==> 4 611 686 018 427 387 904

Actually, the whole hack should be done away with, but as far as I can tell, 
this is still the way it is in the latest version of the code.

The problem this causes is that there are extra bits set in the group's "bit" 
field, which causes group memberships to display incorrectly, among other 
things. (I spotted the first one -- the 65535 -- easily, which made me search 
for other errors just to be safe. I don't have the powers of two memorized or 
anything!)

Comment 1

18 years ago
Well, this is something we'll have to look at as we hash out 2.14.  Thanks for
the heads up (I don't think many people have enough groups to see that... esp.
the last two!).
Target Milestone: --- → Bugzilla 2.14
Bug 47561 is RESOLVED/FIXED.  Patch was checked into CVS on 2000-09-14.


*** This bug has been marked as a duplicate of 47561 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
clearing milestone on closed non-FIXED bugs in case they ever get reopened.
Target Milestone: Bugzilla 2.14 → ---
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.11 → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.