Closed Bug 706420 Opened 8 years ago Closed 8 years ago

intermttent toolkit/components/places/tests/expiration/test_annos_expire_session.js | true == false OR | Should not find any leftover session annotations

Categories

(Toolkit :: Places, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: mak, Assigned: mak)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=7653592&tree=Firefox

TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_session.js | running test ...
TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_session.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>

TEST-INFO | (xpcshell/head.js) | test 1 pending

TEST-INFO | (xpcshell/head.js) | test 2 pending

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 81] 10 == 10

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 83] 10 == 10

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 85] 10 == 10

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 87] 10 == 10

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | running event loop

TEST-UNEXPECTED-FAIL | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | true == false - See following stack:
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_throw :: line 453
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _do_check_eq :: line 547
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_eq :: line 568
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_false :: line 596
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js :: <TOP_LEVEL> :: line 95
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/head_expiration.js -> file:///c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/head_common.js :: <TOP_LEVEL> :: line 634
This orange is almost permanent on Thunderbird's (VM) Windows builders - anything I can do to help debug?
Could you please link one of these failures?
I have an idea we may try
Assignee: nobody → mak77
Attached patch patch v1.0Splinter Review
Attachment #596995 - Flags: review?(mbanner)
Comment on attachment 596995 [details] [diff] [review]
patch v1.0

This looks great. From a few runs on our try server this seems to be passing consistently as well. Thanks.
Attachment #596995 - Flags: review?(mbanner) → review+
yeah, I think previously the async statement was sometimes executes synchronously, and it was correctly failing.
https://hg.mozilla.org/integration/mozilla-inbound/rev/c79e879427cd
Target Milestone: --- → mozilla13
looks like there is still something broken

https://tbpl.mozilla.org/php/getParsedLog.php?id=9380718&tree=Mozilla-Inbound
Summary: intermttent toolkit/components/places/tests/expiration/test_annos_expire_session.js | true == false → intermttent toolkit/components/places/tests/expiration/test_annos_expire_session.js | true == false OR | Should not find any leftover session annotations
https://hg.mozilla.org/mozilla-central/rev/c79e879427cd
will check again what may still cause a failure
ah ugh, since this is a new connection it is concurrent to the old one... fix incoming.
The ASYNC_BIND removal is not directly related to this fix, though I noticed it while checking the annotations service cleanup on shutdown and since it's useless work I decided to kill it. no reason to use a mozIStorageBindingParamsArray unless the query should run multiple times with different bound params.
Attachment #597755 - Flags: review?(dietrich)
Attachment #597755 - Flags: review?(dietrich) → review+
https://hg.mozilla.org/mozilla-central/rev/bdb4708a2950
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.