Username with capital letter remembered as small letter => "invalid username error"




6 years ago
4 years ago


(Reporter: noitidart, Unassigned)


Firefox Tracking Flags

(Not tracked)





6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

My username is Noitidart with a capital N. Firefox remember my username as noitidart with lower n. So when I type in Noitidart, as I click to password field it lower cases the n. So whenever I try to login, it tells me invalid username.

This is a firefox browser problem huh?

Actual results:

swithces to lower case version that is remembered

Expected results:

it should not switch to lower case version/remembered version if i dont click on it.

Comment 1

6 years ago
[Please describe the problem in the bug summary, instead of posting an URL. Thanks.]
Summary: → Username with capital letter remembered as small letter => "invalid username error"

Comment 2

6 years ago
thanks so sorry about that
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 680538

Comment 4

6 years ago
This is not a dupe of bug 680538 (& I don't think I can undupe/reopen it?). That bug is about the AMO Forum software, this bug is about Firefox itself.

This bug is about the Firefox Password Manager remembering his login info with a lowercase username (probably how he originally told it to remember it) & not letting him override/update that remembered username.

It was probably always remembered as lowercase...& always worked, until bug 680538 was fixed. Fixing bug 680538 caused a slight case-sensitive username issue, for which I've posted a possible solution.

So this bug should be about letting Firefox be taught to "forget the old username" & "let me give you a new username to remember".

So, to try to reproduce this bug, remember a username/password for ANY site...

Username: testing
Password: testing

...logout of that site & try to login again, this time try to type the username differently...

Username: TESTing

...according to his report, if you type the username, with a different case than what was remembered, once you move to the password field, Firefox will helpfully lowercase -- or "return to the remembered case" -- the username, thinking you typed it wrong. Firefox should not fight you on this. It should allow you to type the username with a different case & leave you alone.

I believe there should be a way to...

1. Forget the old-cased username & remember the new one.
2. Remember both cases of username (if desired).
Component: Forums → General
Ever confirmed: true
Product: → Firefox
QA Contact: forums → general
Resolution: DUPLICATE → ---
Version: 1.0 → unspecified

Comment 5

4 years ago
This is a dup of bug #499649, I think.
You need to log in before you can comment on or make changes to this bug.