Last Comment Bug 706447 - Assertion failure: isMarkStackEmpty(), at js/src/jsgc.cpp:1781
: Assertion failure: isMarkStackEmpty(), at js/src/jsgc.cpp:1781
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- critical (vote)
: ---
Assigned To: Bill McCloskey (:billm)
:
: Jason Orendorff [:jorendorff]
Mentors:
: 706646 (view as bug list)
Depends on:
Blocks: langfuzz
  Show dependency treegraph
 
Reported: 2011-11-30 05:37 PST by Christian Holler (:decoder)
Modified: 2011-12-06 16:11 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Christian Holler (:decoder) 2011-11-30 05:37:50 PST
The following test asserts on larch branch (incremental GC) revision (options -m -n -a):

var i = 10;
while (i > 0) {
  try {
    eval("var HEAP, IHEAP, FHEAP;\nvar TOTAL_MEMORY = 50 * 1024 * 1024;\nHEAP = IHEAP = new Int32Array(TOTAL_MEMORY);\nvar _rng;\nvar __str2;\nvar __str3;\n    var __stackBase__ = STACKTOP;\n    var $n;\n    var $tmp5 = __stackBase__ + 12;\n    var $tmp6 = $n;\n    var $mul7 = ($tmp6) * 3;\n    var $mul_i = ($tmp_i) * 3877;\n    var $add_i = ($mul_i) + 29573;\n    var $rem_i = ($add_i) % 139968;\n    var $last2_i = $this1_i;\n    var $tmp3_i = $max_addr_i;\n    var $last4_i = $this1_i;\n    var $tmp5_i = let ( a2 , v      ) (function(IHEAP){return Math.$this1_i(z);})   [$last4_i];\n    var $conv_i = ($tmp5_i);\n");
  } catch (lfVare) {    }
  i--;
}


Sorry for the messy test, I wasn't able to remove the load/eval here.
Comment 1 Christian Holler (:decoder) 2011-11-30 05:54:12 PST
Forgot the revision, it's 7f5adef938aa.
Comment 2 Bill McCloskey (:billm) 2011-11-30 11:44:43 PST
https://hg.mozilla.org/projects/larch/rev/ecb527746947
Comment 3 Bill McCloskey (:billm) 2011-12-06 16:11:55 PST
*** Bug 706646 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.