Empty Search query should return all existing (enabled) Apps

VERIFIED DUPLICATE of bug 705853

Status

VERIFIED DUPLICATE of bug 705853
7 years ago
3 years ago

People

(Reporter: johnny.mozbugs, Assigned: cvan)

Tracking

unspecified
6.3.3

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 577968 [details]
empty_search_query

1. Load https://apps-preview-dev.allizom.org/en-US/apps/search/?q=
Alternatively, you can search for empty query by loading https://apps-preview-dev.allizom.org/en-US/apps/ and clicking on the green arrow next to search.
2. Observe the results.

Actual Result: "Oops! We had an error.
We'll get to fixing that soon.
You can try refreshing the page, or head back to the Apps homepage."

Expected Result: The results should contain all Apps - just like blank search for Add-ons.
(Reporter)

Comment 1

7 years ago
--
[18:24:32.120] GET https://apps-preview-dev.allizom.org/en-US/apps/search/?q= [HTTP/1.1 500 INTERNAL SERVER ERROR 2578ms]
--
[18:24:37.899] GET https://browserid.org/include.js [HTTP/1.1 304 Not Modified 2953ms]

http://screencast.com/t/FWWya5RHn
(Assignee)

Updated

7 years ago
Assignee: nobody → cwiemeersch
(Assignee)

Comment 2

7 years ago
https://apps-preview-dev.allizom.org/en-US/apps/search/?q= works for me. I think you may have hit a TimeoutError - hence the 500.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 3

7 years ago
He actually hit a traceback reported at bug 705853
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 705853
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.