Closed Bug 706497 Opened 9 years ago Closed 9 years ago

Intermittent mochitest INFO | runtests.py | Received unexpected exception while running application 'unable to launch process'

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 706614

People

(Reporter: mbrubeck, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [mobile_unittests][android-tier1][tegra][birch])

From three different mochitest-2 runs on Birch in the past day:
https://tbpl.mozilla.org/php/getParsedLog.php?id=7652469&tree=Birch
https://tbpl.mozilla.org/php/getParsedLog.php?id=7651539&tree=Birch
https://tbpl.mozilla.org/php/getParsedLog.php?id=7652418&tree=Birch

========= Started 'python mochitest/runtestsremote.py ...' warnings (results: 1, elapsed: 55 secs) ==========
python mochitest/runtestsremote.py --deviceIP 10.250.49.77 --xre-path ../hostutils/xre --utility-path ../hostutils/bin --certificate-path certs --app org.mozilla.fennec --console-level INFO --http-port 30089 --ssl-port 31089 --pidfile /builds/tegra-089/test/../runtestsremote.pid --test-path js
 in dir /builds/tegra-089/test/build/tests (timeout 2400 secs)
 watching logfiles {}
 argv: ['python', 'mochitest/runtestsremote.py', '--deviceIP', '10.250.49.77', '--xre-path', '../hostutils/xre', '--utility-path', '../hostutils/bin', '--certificate-path', 'certs', '--app', 'org.mozilla.fennec', '--console-level', 'INFO', '--http-port', '30089', '--ssl-port', '31089', '--pidfile', '/builds/tegra-089/test/../runtestsremote.pid', '--test-path', 'js']
 environment:
  PATH=/opt/local/bin:/opt/local/sbin:/opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
  PWD=/builds/tegra-089/test/build/tests
  SUT_IP=10.250.49.77
  SUT_NAME=tegra-089
  __CF_USER_TEXT_ENCODING=0x1F6:0:0
 closing stdin
 using PTY: False
unable to execute ADB: ensure Android SDK is installed and adb is in your $PATH
restarting as root failed
reconnecting socket
INFO | runtests.py | Installing extension at /builds/tegra-089/test/build/tests/mochitest/extensions/specialpowers to /tmp/tmpMJF8UO.
INFO | runtests.py | Installing extension at /builds/tegra-089/test/build/tests/mochitest/extensions/worker to /tmp/tmpMJF8UO.
INFO | runtests.py | Installing extension at /builds/tegra-089/test/build/tests/mochitest/extensions/workerbootstrap to /tmp/tmpMJF8UO.
pushing directory: /tmp/tmpMJF8UO to /mnt/sdcard/tests/profile
args: ['/builds/tegra-089/test/build/hostutils/bin/xpcshell', '-g', '/builds/tegra-089/test/build/hostutils/xre', '-v', '170', '-f', './httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmp2UpPg1';const _SERVER_PORT = '30089'; const _SERVER_ADDR ='10.250.48.211';", '-f', './server.js']
INFO | runtests.py | Server pid: 76713
pushing directory: /tmp/tmpMJF8UO to /mnt/sdcard/tests/profile
INFO | runtests.py | Running tests: start.

FIRE PROC: '"MOZ_CRASHREPORTER=1,XPCOM_DEBUG_BREAK=stack,MOZ_CRASHREPORTER_NO_REPORT=1,NO_EM_RESTART=1,MOZ_PROCESS_LOG=/tmp/tmpu09lGRpidlog,XPCOM_MEM_BLOAT_LOG=/tmp/tmpMJF8UO/runtests_leaks.log" org.mozilla.fennec -no-remote -profile /mnt/sdcard/tests/profile/ http://mochi.test:8888/tests/js?autorun=1&closeWhenDone=1&logFile=%2Fmnt%2Fsdcard%2Ftests%2Flogs%2Fmochitest.log&fileLevel=INFO&consoleLevel=INFO'
INFO | runtests.py | Received unexpected exception while running application 'unable to launch process'

WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
DeviceManager: error pulling file '/mnt/sdcard/tests/logs/mochitest.log': No such file or directory
removing file: /mnt/sdcard/tests/logs/mochitest.log
program finished with exit code 1
elapsedTime=55.792306
TinderboxPrint: mochitest-plain_3<br/><em class="testfail">T-FAIL</em>
Unknown Error: command finished with exit code: 1
======== Finished 'python mochitest/runtestsremote.py ...' warnings (results: 1, elapsed: 55 secs) ========
Nevermind, this isn't the actual error - this happened as a later consequence of an earlier error in the test run.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Filed bug 706614 for the actual failure in most of these cases.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 706614
Whiteboard: [orange][mobile_unittests][android-tier1][tegra][birch] → [mobile_unittests][android-tier1][tegra][birch]
You need to log in before you can comment on or make changes to this bug.