Crash in mozalloc_abort(char const* const) | NS_DebugBreak_P | write_string

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
7 years ago
15 days ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86_64
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It first appeared in build 11.0a1/20111124.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3c8147998124&tochange=de483d897af4
It might be caused by bug 680556.

Signature	mozalloc_abort(char const* const) | NS_DebugBreak_P | write_string
UUID	3845d448-17e9-471a-a758-5e7662111201
Date Processed	2011-12-01 01:14:04.716443
Uptime	49
Last Crash	5.5 minutes before submission
Install Age	13.8 hours since version was first installed.
Install Time	2011-11-30 19:26:39
Product	Firefox
Version	11.0a1
Build ID	20111130031011
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7600
Build Architecture	amd64
Build Architecture Info	family 6 model 23 stepping 10
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x7fef8681b23
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 061e, AdapterSubsysID: 0539103c, AdapterDriverVersion: 8.17.12.7600
D2D? D2D+
DWrite? DWrite+
D3D10 Layers? D3D10 Layers+
xpcom_runtime_abort(###!!! ABORT: other side should have been blocked: file e:/builds/moz2_slave/m-cen-w64-ntly/build/ipc/glue/RPCChannel.cpp, line 683)
Processor Notes 	This dump is too long and has triggered the automatic truncation routine
EMCheckCompatibility	True

Frame 	Module 	Signature [Expand] 	Source
0 	mozalloc.dll 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:77
1 	xul.dll 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:345
2 	msvcr90.dll 	write_string 	f:\\dd\\vctools\\crt_bld\\self_64_amd64\\crt\\src\\output.c:2553
3 	mozutils.dll 	imalloc 	memory/jemalloc/jemalloc.c:4112
4 	msvcr90.dll 	output_l 	f:\\dd\\vctools\\crt_bld\\self_64_amd64\\crt\\src\\output.c:2360
5 	mozutils.dll 	choose_arena 	memory/jemalloc/jemalloc.c:2891
6 	mozutils.dll 	je_realloc 	memory/jemalloc/jemalloc.c:6466
7 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6230
8 	xul.dll 	Pickle::Pickle 	ipc/chromium/src/base/pickle.cc:59
9 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6230
10 	xul.dll 	IPC::Message::Message 	ipc/chromium/src/chrome/common/ipc_message.cc:49
11 	mozutils.dll 	je_free 	memory/jemalloc/jemalloc.c:6504
12 	xul.dll 	std::_Vector_const_iterator<unsigned char,std::allocator<unsigned char> >::operator== 	vector:208
13 	xul.dll 	std::_Vector_const_iterator<ots::OpenTypeCMAPSubtableVSMapping,std::allocator<ots::OpenTypeCMAPSubtableVSMapping> >::operator!= 	vector:216
14 	xul.dll 	std::deque<IPC::Message,std::allocator<IPC::Message> >::_Insert<std::_Deque_const_iterator<IPC::Message,std::allocator<IPC::Message>,1> > 	deque:1012
15 	xul.dll 	std::_Container_base_aux_alloc_real<std::allocator<IPC::Message> >::_Container_base_aux_alloc_real<std::allocator<IPC::Message> > 	xutility:420
16 	xul.dll 	std::deque<IPC::Message,std::allocator<IPC::Message> >::insert<std::_Deque_const_iterator<IPC::Message,std::allocator<IPC::Message>,1> > 	deque:960
17 	msvcr90.dll 	getptd_noexit 	f:\\dd\\vctools\\crt_bld\\self_64_amd64\\crt\\src\\tidtable.c:616
18 	msvcr90.dll 	errno 	f:\\dd\\vctools\\crt_bld\\self_64_amd64\\crt\\src\\dosmap.c:281
19 	mozutils.dll 	je_free 	memory/jemalloc/jemalloc.c:6504
20 	xul.dll 	Pickle::~Pickle 	ipc/chromium/src/base/pickle.cc:64
21 	xul.dll 	IPC::Message::`vector deleting destructor' 	
22 	xul.dll 	std::deque<IPC::Message,std::allocator<IPC::Message> >::pop_front 	deque:834
23 	xul.dll 	mozilla::ipc::RPCChannel::DebugAbort 	ipc/glue/RPCChannel.cpp:683
24 	xul.dll 	IPC::Message::`vector deleting destructor' 	
25 	xul.dll 	mozilla::ipc::AsyncChannel::SendThroughTransport 	ipc/glue/AsyncChannel.cpp:317
26 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:251
27 	mozutils.dll 	je_realloc 	memory/jemalloc/jemalloc.c:6466
28 	xul.dll 	Pickle::Resize 	ipc/chromium/src/base/pickle.cc:494
29 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6230
30 	xul.dll 	IPC::Message::Message 	ipc/chromium/src/chrome/common/ipc_message.cc:41
31 	xul.dll 	Pickle::Pickle 	ipc/chromium/src/base/pickle.cc:38
32 	xul.dll 	mozilla::plugins::PPluginInstance::Msg_UpdateWindow::Msg_UpdateWindow 	obj-firefox/ipc/ipdl/_ipdlheaders/mozilla/plugins/PPluginInstance.h:4076
33 	xul.dll 	mozilla::plugins::PPluginInstanceParent::CallUpdateWindow 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:1025
34 	xul.dll 	nsWindow::OnPaint 	
...

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=30&range_unit=days&signature=mozalloc_abort%28char%20const*%20const%29%20|%20NS_DebugBreak_P%20|%20write_string
Component: jemalloc → IPC
QA Contact: jemalloc → ipc
(Reporter)

Comment 1

7 years ago
(In reply to Scoobidiver from comment #0)
> It first appeared in build 11.0a1/20111124.
> The regression range is:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=3c8147998124&tochange=de483d897af4
I missed one crash in 11.0a1/20111123. So the regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ceaedf06a57&tochange=3c8147998124
It might be caused by bug 703942.

Updated

3 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | write_string ] → [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | write_string ] [@ mozalloc_abort | NS_DebugBreak_P | write_string ]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 15 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.